Website Interactivity is Slow

I believe that apart from “Hyper-V”, Docker als requires the “Containers” option enabled in “Turn Windows features on or off”. Maybe that is the issue?

@GoldyOnline Wow! Thanks so much for digging into this! I’ve sent this over to the devs to review:pray:

1 Like

Just switched to Hyper-V (ie, unchecked using WSL 2 in Docker) and WOW, what a difference!! Load times went from mid 20s to mid 2s :astonished:

Thanks for the details, and note on backing up your databases before switching @GoldyOnline


This works for me too. Finally normal loading times :wink:
Thanks for sharing this!


Amazing! Thank you so much! Speed went up 10-fold!

1 Like

You’re an absolute lifesaver :partying_face:. I have multiple dev sites that thankfully do not rely on the database content. But after an update to WSL2 the databases were lost, and performance dropped significantly. I’ve been trying to remedy since and was afraid to turn of WSL2 base engine. But that did the trick for me, everything else was already as you described.
Load times are about 10 times faster. Now of to rebuild my workspaces…

1 Like

@ GoldyOnline Upgrading to Windows 10 Pro indeed fixed the problem, thank you for figuring this out.

@ melissa Altough the actuel fix should come from DevKinsta, our entire team works on Windows Home. So that would mean to be able to make DevKinsta work you need to upgrade to Windows Pro. That isnt a real solution :wink: Any news on this?

1 Like

Not yet I’m afraid, though upgrading to Windows Pro is not necessary in all cases. We do have several users that have Windows Home that are not experiencing this issue which adds to the confusion for us. It appears an issue with Docker and Windows but we’re working on possible solutions and writing an official guide for users experiencing this issue.

I also notice some dramatic performance issues since switching to DevKinsta. I’m on a MacBook Pro (BigSur 11.5.2 / 32GB RAM / 2.9GHz 6-core)

Here’s what I observe:

  1. The more websites I add, the slower it gets
  2. The performance gets better, when I quit PhpStorm and only have DevKisnta + Browser open
  3. Performance degrades when a download is running (regardless of plugin update or just downloading a random file from a different website)
  4. When using Dockers option “Use new Virtualization Framework” performance goes really bad. Like 90 seconds for each click (hyperkit is faster!).
  5. Performance improved, once I moved most websites from “~/DevKinsta/public” to the new folder “~/DevKinsta/archive” (I left the DB, only moved the files)
  6. Performance is bad right after starting up DevKinsta and improves after 5-10 minutes
  7. Enabling Xdebug makes each request about 0.5 seconds slower

Here are some numbers (I tested each case 5-8 times, here is the mean value):

Websites Files / Size IDE Download Load-Time
1 488.000 / 4GB - - 1.2 sec
1 488.000 / 4GB - yes 2.4 sec
1 488.000 / 4GB running - 1.4 sec
1 488.000 / 4GB running yes 6.0 sec
2 529.000 / 8GB - - 1.6 sec
2 529.000 / 8GB - yes 2.7 sec
2 529.000 / 8GB running - 1.6 sec
2 529.000 / 8GB running yes 6.1 sec
4 1.030.000 / 14GB - - 2.3 sec
4 1.030.000 / 14GB - yes 5.4 sec
4 1.030.000 / 14GB running - 2.2 sec
4 1.030.000 / 14GB running yes 11.6 sec


  • Websites: Number of Websites in DevKinsta
  • Files: Total number of files in the ~/DevKinsta/public folder
  • IDE: Is PhpStorm running with a DevKinsta project loaded, or quit?
  • Download: Is a download in progress? (I downloaded the Ubuntu ISO)
  • Load-Time: Average load time of website.local/wp-admin

I’ve also had load-times of 60+ seconds, and it seems to be directly related to file system activity - e.g. when having other apps open, like an FTP and DB client. My previous server was very consistent, regardless of file system activity. It’s possibly related to Dockers integration with the Apple APFS.

My solution/recommendation:

  • Do NOT enable the new virtualization framework on Big Sur!
  • Keep the public folder slim → move the wp-contents folder of inactive sites somewhere outside the public folder, but keep the rest, as DevKinsta will delete the website otherwise
  • Close unused apps to minimize file system access
  • Do not download files in the background
  • Start DevKinsta, get a coffee and start working after all containers and indices were initialized

When is this going to get fixed? I just spent ages getting this set up and now I find it’s so slow it’s useless. Then I see that ppl have been complaining since January about it. what’s the delay?

Welcome to DevKinsta @sparkzilla ! Unfortunately, it’s a bit more complex than what it appears on here. While we’ve made some improvements with version 2.2.0, many of the issues being faced here are specific to Docker, the operating system, and the operating system configuration. It’s often not directly related to DevKinsta. If you’re on Windows 10, I recommend following this guide here. I understand this is still not ideal. We’re working to resolving these issues in as many scenarios as possible. I’m really sorry for the trouble here!

Also raised here: Increase local PHP performance - #4 by sonicviz
Using Hyper-V.

The site I’ve imported to DevKinsta is unusably slow, so I’m trying these recommendations. I was already on Win10 Pro, so I started with enabling Hyper-V, did all the restarts, and … oops, how do I import the databases in the new environment (step 8)? Do I have to delete and re-add the site in DevKinsta?

@DavidMitchell what I find easiest is to just export the mysql databases in the old local environment and import them in the new environment. So if you already switched to Hyper-V, and in case you didn’t export the dbs yet, then temporarily switch back to WSL 2, then you can access the mysql dbs of the “old” local environment. You export them, and then switch again to Hyper-V, and then you import the mysql dbs.
The exports, and imports of the mysql dbs can be done simply via the Adminer environment that you launch from Devkinsta via the “three dots” and then > Open database manager


@GoldyOnline, thank you very much. Apparently I skipped right over step 3 in your post above — sorry about that. Thanks for patiently getting me back on track!

The site I’ve imported is still much slower than on Kinsta’s staging server (not at all what I was hoping for!), but several times faster than it was to start with, so it’s at least somewhat usable.

1 Like

I came across Microsoft’s “Exceptions for using WSL 1 rather than WSL 2” a while ago. Is this why WSL 2 is problematic with DevKinsta?

Consider using WSL 1 if:

  • Your project files must be stored in the Windows file system. WSL 1 offers faster access to files mounted from Windows.
    • If you will be using your WSL Linux distribution to access project files on the Windows file system, and these files cannot be stored on the Linux file system, you will achieve faster performance across the OS files systems by using WSL 1.

Hello there,

Like many people on this thread, I follow all the tricks to make things better (performances are really really bad on my Ryzen 5 Pro with 8Gb of RAM, Win10 Pro), but I’m stuck on creating containers (error DK0005) when I launch DevKinsta with WSL2 disabled (Hyper-V is installed and Up). So I have to revert back to WSL2 to make DevKinsta working.

I would like to know when this will be fixed. Honestly it is not possible to work in good condition. This is frustrating as your tool is really a good one.

Thanks for your support!

All the best,


I had the DK0005 issue in the past as well, fortunately, there is an easy fix for this:

(assuming that it’s the same folder access issue that you are having)

Hopefully that helps?



It works! Many thanks for your help!




Is there any news on this? I’ve followed the suggestions in the thread and fortunately, it’s worked for me with a bit of trial and error. It’s still not super ideal though.

Switching between hyper-v and wsl to fix the database every time you make a new local site is a little too round about. It doesn’t look like I can just switch to hyper-v and forget it either, but correct me if someone else has a different experience. Adding a site when I’m it’s set to hyper-v doesn’t work and throws me a DDK0029 error (iirc).

I tried placing the kinsta files (settings > site path) on the wsl side of things hoping being on the same filesystem would speed it up but it didn’t work quite well. The sites are downloaded as expected and I think most things are working but opening the site
gives me a 404 error instead.

Any new experience from anyone still working with it? Or is the de facto way to get around this still switching back and forth wsl and hyper-v?