Cant create mysql dump DK0029

Hi ,

Trying to pull a site from DevKinsta app. Been getting DK0029 error. Tried several times with no luck.
Log shows permission error?

Edit : was trying to pull a live site.

Things I’ve tried.

  • Deleted SSH file (as per another thread with the same issue). No luck.
  • Logout and login to regenerate ssh file (would fix permission issue as per another thread). No luck.

[2022-05-25 12:44:50.220] [error] Error - DK0029: MYSQL_DUMP_COMMON: Error (255): Cssh: connect to host 35.244.**.** port 12870: Connection refused
    at /Applications/
    at tryCatch (/Applications/
    at Generator._invoke (/Applications/
    at (/Applications/
    at asyncGeneratorStep (/Applications/
    at _next (/Applications/
    at processTicksAndRejections (node:internal/process/task_queues:96:5)

Hi @bigarashi, welcome to DevKinsta!
Are you using version 2.6.0 of DevKinsta? Can you please private message the full main.log to me as well as the live site url? I’ll be able to check the server logs to see what’s going on.

Thanks for sharing that @bigarashi! Can you also try creating a staging environment and repeating this process just to be sure it fails in the same manner?

I see a potential issue with the mysqldump command but I’m not sure why this is only occurring for you. I’m going to ask our devs to review as well!

Hey @bigarashi, can you please try this again with the Live site? We tracked down an issue with the ssh port that should be resolved now. I think that should allow you to pull the Live site without issue.