DK0029 - Can't create mysql dump

I have the latest versions of Docker and DevKinsta installed.

The operating system is Windows 10.

After solving the problem with NGINX configuration and creating the database, I have another problem that I cannot deal with.


[2022-06-22 17:25:07.686] [error] [ipcMainStep] Error in operation SITE_CREATION, step rsync: Error - DK0029: MYSQL_DUMP_COMMON: Error (255): 6Connection to closed by remote host.
    at D:\Programy\Kinsta\resources\app.asar\
    at tryCatch (D:\Programy\Kinsta\resources\app.asar\
    at Generator._invoke (D:\Programy\Kinsta\resources\app.asar\
    at (D:\Programy\Kinsta\resources\app.asar\
    at asyncGeneratorStep (D:\Programy\Kinsta\resources\app.asar\
    at _next (D:\Programy\Kinsta\resources\app.asar\
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
[2022-06-22 17:25:07.723] [info]  [editGlobalPhpIni] Getting content from  /www/kinsta/public/mywebsitename/.user.ini
[2022-06-22 17:25:07.723] [info]  [ViewSite] checking site unread emails
[2022-06-22 17:25:07.724] [info]  [dockerUtil/getContainer] Get 'devkinsta_fpm' Docker container
[2022-06-22 17:25:07.725] [info]  [getSiteMailbox] Update site mailbox with API query: search?kind=containing&query=mywebsitename.local
[2022-06-22 17:25:07.731] [info]  [getSiteMailbox] 0 emails retrieved. for domain mywebsitename.local
[2022-06-22 17:25:07.739] [info]  [ProgressIndicator] { isFailed: true, isOpen: true }
[2022-06-22 17:25:08.746] [info]  [containerExec] Command 'test -f /www/kinsta/public/mywebsitename/.user.ini && echo $?' on devkinsta_fpm finished with exit code 1
[2022-06-22 17:25:08.746] [info]  [PhpIniEditor] Loading content into editor: 
[2022-06-22 17:28:42.049] [info]  [useMailhog] Mail socket closed.

From there: DevKinsta Error Codes - Kinsta®
Try it again later. If it still doesn’t help, please report this error to the DevKinsta Community Forum.

I tried yesterday and today. Unfortunately, the problem still persists.


Hi @bigwp, welcome to DevKinsta!
This error is implying that the SSH connection from your PC to your site is failing for some reason. Are you able to open your command prompt/terminal and connect to your target site using SSH? Please feel free to private message your Kinsta site URL to me so that I can check the access logs to see why the connection is being rejected.

Thanks for sharing that @bigwp, can you try these steps:

  1. Go to settings and log out of your MyKinsta account.
  2. Completely close DevKinsta
  3. Delete the ~/DevKinsta/.ssh folder
  4. Open DevKinsta and log back into MyKinsta (if it fails, please let me know the approximate time of your test with your timezone)

The logs seem to show successful SSH connections from your computer but I will need to doublecheck after your next attempt. Please also private message your IP address to me so we can check our firewall on our end.

I’ve done this a couple of times now because I’ve seen the same issues on other threads. Unfortunately, in my case it did not help either.
This time it is similar. I logged out, shut down DevKinsta completely, deleted the SSH folder, restarted the application (this is where the .shh directory is created), logged in without any problems. Unfortunately, the problem persists.
I sent my IP address in a private message. Thank you.