Could not restart nginx service DK0073

Q: Date/Time this occurred (Provide your time zone also)

Multiple times since a week or so ago

Q: DevKinsta Version

Q: OS Version
Win 11 latest

Q: Docker Desktop Version
V4.11.1 WSL2 Ubuntu 20.04

Q: Were any error codes or messages observed? If so, what were they?
Could not restart nginx service DK0073 (see attached image)

Q: Detailed Description of the Problem

A week or so ago my DevKinsta install started refusing to start up, showing this error “Could not restart nginx service DK0073”.
I was on a docker desktop using Hyper-V, and previously had been working fine (other issues raised here aside).

I uninstalled DevKinsta and Docker Desktop.

I installed WSL 2 with Ubuntu.
Reinstalled Docker for Desktop (windows) using WSL2 (aok)
Installed DevKinsta aaaaaaaaaaand

same error.

It continually tries to restart the nginx container in DFW, and last time I looked at the DevKinsta log it seemed to be an issue with port 442 (used by DevKinsta nginx container) as being used.

But a port scan shows port 443 is not being used by anything.
I thought initially it may be due to an VPN I installed (Private Internet Access) but that’s not it (uinstalled, changed it’s local port, didn’t run it) but it doesn’t seem to be the issue either.

Now, I can’t even open DevKinsta. Because I closed it the first time, it won’t restart, as now it gets a “DK005 couldn’t create docker containers error”
So the only way to get DevKinsta to run is to delete all the containers again, but then the nginx one still fails to start again.

What is up with this? Any clues?
Can you change the DevKinsta nginx port 443 to test another one or something?
As I mentioned though, port scan on windows shows port 443 is not being used locally anyway (chrome uses it, but that’s local to remote connections).

Paul, your most obedient DevKinsta bug magnet.

Hi @sonicviz , thanks for reaching out! Have you already tried changing your Port selector from “auto detect?”

What does the docker logs devkinsta_nginx command return when that’s failing to start? Or if you can’t get to those logs can you please private message your main.log file to me with a summary of the current state of DevKinsta?