Default langage not working (only english)

When I create a new Wordpress site from DevKinsta, the site langage is always “English” and there are no other options to switch in the “Settings > General > Site settings” select.
In DevKinsta settings, I have tried both “Use Windows lang” and manually selecting the lang, but without succes.
Let me know if it’s a known issue and how it can be solve
Thanks a lot

Hi @tibbarm! Welcome to the Kinsta community!

Thanks for reaching out to us! I understand that when you create a new WordPress site using DevKinsta, the site defaults to English rather than the language you select for the DevKinsta application itself.

I am also able to replicate this on my end. I am going to forward this information to our development team to consider including the option to set a default website language in a future release of DevKinsta.

To change the language of your site currently, you may login to the WordPress dashboard and navigate to Settings >> General, and set the site language on that page.

Thank you again for reaching out. If you do have any questions or need any assistance with changing the site language in the WordPress settings please don’t hesitate to reply.

Best regards

Problem is that there are no other langage to choose in the Wordpres dashboard (Settings >> General), the select contain only one option (English)

Hello @tibbarm :wave:

This seems to be specific to the installation. I have checked on my DevKinsta and I am able to change the language.

There’s an old thread which has some suggestions, first one being adding:

define(‘FS_METHOD’, ‘direct’);

Please try this and let me know if it works for you.

Kind regards

1 Like

Yep this worked thanks. Now hope to see the default wordpress langage working in a future release :slight_smile:

Hi @tibbarm,

Thank you for the update and we are glad that it is working now.
If ever you encounter any issues, please feel free to reach out.

Have a great day!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.