DevKinsta shuts down on start

Installed DK a few weeks ago, all worked great, made a simple WP site to test, everything ok.
After a few days it stopped working. It shuts down after a glimpse of showing the splash image…
No errors, no nothing… just shuts down inmediatelly.
I uninstalled, installed again… same problem… any ideas?

Mac OSX Ventura, Mac Mini M2 chip.

Hi @luccas222 and welcome to DevKinsta Community!
Can you please send to @ZachE, @Agus and me a copy of your main.log file via DM? You can find it at this path:


We’d like to give a look at it and help you find the culprit.


tks in advance

Hello Gerry,

Thank you for your reply along with that main.log file.
As far as I could see, the most recent error shown in that file was the following:

[2023-05-15 11:00:00.958] [error] watchDocker - Error: connect ECONNREFUSED /var/run/docker.sock

it may be related to the Docker engine perhaps.
Can you please try to open terminal program on your mac, and try to run this command line:

sudo ln -s "$HOME/.docker/run/docker.sock" /var/run/docker.sock

close and shutdown the DevKinsta completely, then try to re-launch DevKinsta once again and see if it will open it properly?



Hi Agus!, tks for your help!.
DevKinsta makes the same thing… it shows the splash image for a split second and shuts down.

Thank you for your reply and update Gerry!

OK, so it seem that file exists/already there!
I’ve never experienced this issue before (DevKinsta shows the splash image for a split second and shuts down) :thinking: , and I don’t use Mac either here and can’t replicate it (only use Linux Ubuntu on my laptop and Windows 10 on my spare computer - and they all work just fine) - and yeah so far I couldn’t find any useful information (or other recent errors logged in your main.log file).

Previously you mentioned that you uninstalled and re-installed, did you do it just for the DevKinsta?
If you don’t have any important local sites created in DevKinsta, I would suggest to try to from scratch by uninstalling both of Docker (engine and/or desktop) and the DevKinsta as well as to clean up/remove any Docker’s containers/volumes/networks and also DevKinsta’s folders/data/files and local sites files, etc. - then re-install them:

Let’s see if removing everything and re-installing from scratch will help! :crossed_fingers:


I did, but same thing happened. I will try again tho. Tks for your time, I really appreciate it!.

Ok I’ve uninstalled again both… installed again both… same thing…

Hi @luccas222,
can you please the latest copy of the main.log file? The one in your previous message looks like it’s truncated and no error is really showing. Perhaps try to replicate one more time and after a while get the copy of the file


indeed it’s a truncated one, I deleted the previous one, and tried to start devKinsta, it logs what it does, and then shuts down. If I do that a few times, you will end up with a bunch of the same.
main.log (15.4 KB)

Hey @luccas222 can you please open the app called “Console” and see if there’s anything related to DevKinsta inside the Crash or Spin report tab?

Thanks for the tip, but no… nothing about devkinsta or docker either

Hey @luccas222 I’ve asked our developers if there’s something else they suggest. Please keep us in the loop if anything changes on your side.