DK0029 error: Can’t create mysql dump

I am a Kinsta user.
2 weeks ago I managed to install a copy of my WP (production) hosted on Kinsta, into DevKinsta.

Then I messed up with the WP on DevKinsta, and decided to delete the website.
Today, when I try to install anew copy of my WP (production) hosted on Kinsta, into Dekinsta, I have a DK0029 Error.

I have deleted the staging environment on Kinsta. Same result.
Then I deleted on site from DevKinsta. Same result.

I found a solution. Creating a fresh Staging Environment on Kinsta, and pulling it into DevKinsta.
Not sure if it’s the best solution? What do you think?

Hi Alex,

Can you reach out to our support team via MyKinsta so they can take a look at your production site?

There may be an issue there that we can address and fix for you with the database as it sounds like it may be a configuration issue.

Hi @AlexM . Apologies for the trouble here. This is indeed a bug and our dev team is looking at this.

Here’s a workaround to resolve this issue. Are you familiar with using Terminal? The following command should fix this:

docker exec -it devkinsta_fpm /bin/rm /root/.ssh/known_hosts

Please let me know if you have any trouble with that.

Thank you @michael. Just tried, it works great!

1 Like

Hi @michael , I’m experiencing the same issue. I’m not familiar with the docker terminal and where I can run it. Thank you.

Hi @Myluck_Castaneda . Welcome to DevKinsta! I’m very sorry for this. Our developers are currently working on a fix for this.

@michael is there another way that I can pull my site from Kinsta and work on my local environment?

Hi @Myluck_Castaneda :wave: Certainly! Though it is a manual process at this time. This can be done creating a fresh WordPress install within DevKinsta and then creating a downloadable backup from MyKinsta → Sites → Backups → Download. You would then manually move the files and import the database into DevKinsta.

We have steps on our knowledgebase below that might be of assistance:

I hope that helps!

Thank you @melissa . I will try this. Good thing I already have the downloadable backup. :blush:

1 Like