DK0066: IMPORT_DB_DUMP: Error (1): (ERROR at line 1: Unknown command '\-'

Hello,
I am trying to import database from Kinsta to local via DevKinsta, but it gives me DK0066 error:

[2024-05-29 10:55:29.432] [error] Error - DK0066: IMPORT_DB_DUMP: Error (1): (ERROR at line 1: Unknown command '\-'.
    at *****\DevKinsta\resources\app.asar\main.prod.js:2:757027
    at tryCatch (*****\DevKinsta\resources\app.asar\main.prod.js:8:1829201)
    at Generator.<anonymous> (*****\DevKinsta\resources\app.asar\main.prod.js:8:1830850)
    at Generator.next (*****\DevKinsta\resources\app.asar\main.prod.js:8:1829750)
    at asyncGeneratorStep (**\DevKinsta\resources\app.asar\main.prod.js:8:1821046)
    at _next (*****\DevKinsta\resources\app.asar\main.prod.js:8:1821345)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)

Could you please tell me how to resolve this issue?

Thank you

Hi @taras, Welcome to the Kinsta Community.

I am sorry that you are having issues with your current import using DevKinsta.

Can you please provide us the following information?
DevKinsta Version
OS Version
Docker Desktop Version

Also, have you tried closing Docker and DevKinsta then trying it again?
Can you please send your main.log file via DM so that I can get more information on what caused the issue better?

Looking forward to your response.

Hello Merineth,
Thank you for your reply.

DevKinsta Version: 2.13.2
OS Version: Windows 10 Pro
Docker Desktop Version: 4.30.0

“Also, have you tried closing Docker and DevKinsta then trying it again?”

  • Yes, but it did not resolve the issue :frowning:

“Can you please send your main.log file via DM so that I can get more information on what caused the issue better?”

  • Sure.

Thank you for your help!

Hi @taras thank you for sending in the main.log and for the response.

I’ve investigated this further and I see that the error was generated due to line 1 of the backup.sql file that was imported to your site. See the screenshot below:

Can you please edit the backup.sql file and remove these characters \- of line 1?
Save it then try to reimport it to your local site via DevKinsta. Let me know how it goes.

We are also looking into this and will be doing some further testing to know if this is a potential bug or not. We will keep you posted.

Hi,

My colleagues and I are having the same issue when trying to pull a site from Kinsta, via DevKinsta.

image

I have tried completely reinstalling DevKinsta and Docker, but I still get the same error, I have also attempted to pull known working sites down, but they are also failing when creating them as a new site.

Given that multiple users are experiencing this issue, it seems like this is a bug.

I’ve removed the 1st line in the backup.sql file. Then in DevKinsta, I did: Sync > Pull from Kinsta (Remote Origin / Live), but I still got the same issue.

Hello,

Thank you @taras and @Joe for your replies! I was able to replicate this issue with a newly created site in MyKinsta as well. We have escalated this with our development team and we are investigating into this matter further. We will be providing another update as soon as we have more details to share.

We appreciate your patience while our team investigates into the root cause of this issue and develops a fix.

In the meantime if you do have any questions or have any further details you’d like to share please don’t hesitate to reply!

Best regards

Experiencing this issue as well when trying to pull from Live to local via DevKinsta. Let me know if you’d like a copy of the error log.

@jbdesign :wave:

Welcome to the Kinsta Community!

We’ve informed our development team about the issue you’re experiencing. While we currently don’t have an estimated time for when the issue will be fixed, we’ll notify you as soon as it’s resolved.

My colleagues and I experience the same issue (DK0066). Support told me to remove the - characters from the first line and after that reinstall DevKinsta but with no luck. Tested on multiple sites, none of them can be pulled to local DevKinsta.

I am having the same issue with all my sites.
any updates?

I just looked into the backup.sql and saw there is one more line at the begining, compared to other sql files from devkinsta sites.

/*!999999- enable the sandbox mode */

So i was able to get my site running.

My setup needs my pw before importing the db. So i was able to jump in after the download, opened backup.sql., removed the first line, saved and then the import was good.

Hello @interactivevalues :wave:

Thank you for posting the workaround. We expect the issue to be fixed in our next release which might be available in the next couple of weeks.

We’ll keep you posted.

Kind regards