Docker misery and unable to start DevKinsta

Hi, I’ve been running DevKinsta for some time now on Linux Mint 20.3. All, eventually, worked well.
However when I came to upgrade my system to Linux Mint 21 it reported loads of issues with the Docker repository and refused to update. To get around this I had to uninstall docker ( docker engine ) as well as DevKinsta that obviously broke with no docker. I was then able to complete the upgrade.

So I am now trying to install DevKinsta again. It now prompts me to download Docker Desktop.
I downloaded and installed this. I started Docker Desktop. ( Takes ages to start ).
Tried to install DevKinsta again, which, I think worked. But it is now unable to start Docker and gives me a DK0004 error and to manually start Docker Desktop.
Docker Desktop is already running.

Tried multiple reinstalls, reboots etc. No change.

So how do I fix this?

Also do I have to use Docker Desktop rather than docker-engine? As DevKinsta used to start up almost instantly but now Docker Desktop takes 5 minutes. I have zero other use for Docker and absolutely no wish to have to learn about it TBH.


Fixed it.

I gave up on the Docker Desktop. Instead I installed the Docker Engine ( Install Docker Engine on Ubuntu | Docker Documentation )

This worked and DevKinsta now completes its install and starts. Also its back to the almost instant start as not waiting for the VM of Docker Desktop to trundle into life.

I think that perhaps you could improve the wording of the DevKinsta install so that it doesn’t request Docker Desktop be installed and the link points to the Docker Engine install/download instead.


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.