Error DK0006 on Win10 Pro

Hello, I’m getting the DK0006 error persistently after a fresh install. I’ve checked the other threads and they’re either for Mac or the solutions offered haven’t worked for me.
Windows 10 Pro Build 19044
x64 Intel i7-4770 @3.4 GHz 4 Core
16.0 GB RAM
Internet Okay: 89.9MBPS Down, 10.9MBPS Up.

Windows Defender Firewall is on, but I’ve never had a problem with it before.
The only odd thing I noticed during install was that DevKinsta isn’t signed by the developer so Defender had a fit about that but I bypassed it.

Copied old log file to Desktop.
devkinsta logs.txt (124.5 KB)
Completely unistalled both DevKinsta and Docker.
Purged App Data for both from


Downloaded fresh DevKinsta installer.
Allowed DevKinsta to first-run and go to Docker Download Page
Closed DevKinsta from System Tray and doublechecked TaskMan to see that it was closed for sure. It wasn’t. Killed DevKinsta task through TaskMan.
Ran Docker Installer.
Left WSL at recommended setting.
Ran DevKinsta.
Accept Terms
Docker Starting Up

ERROR DK0006: Couldn’t download docker images.

I read in another thread something vague about HyperV and threading being enabled. I knew it was enabled in BIOS, but never installed the WIN10 Packages. It allowed me to install all but the Hypervisor.

Double check in BIOS that Hyperthreading was enabled. It is.
Copied DEVKinsta log again. Errors are identical to each other with the exception of during install: These were the only errors in the second log.

[2023-01-28 12:01:01.492] [error] Error: connect ENOENT //./pipe/docker_engine
at __node_internal_captureLargerStackTrace (node:internal/errors:465:5)
at __node_internal_exceptionWithHostPort (node:internal/errors:643:12)
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)
[2023-01-28 12:01:01.496] [error] Error: connect ENOENT //./pipe/docker_engine
at __node_internal_captureLargerStackTrace (node:internal/errors:465:5)
at __node_internal_exceptionWithHostPort (node:internal/errors:643:12)
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)

Reinstalled Docker first this time.
Reinstalled DevKinsta.
Allowed Dev Kinsta to first-run.
Same thing.

ERROR DK0006: Couldn’t download docker images.

I also can’t run DevKinsta as an Administrator, or If I can, I don’t know how besides RIGHT CLICK>Run As Administrator. I can do that with Docker, before I launch DevKinsta, but to no avail there.
I searched the Docker Website and found nothing relating to DevKinsta.
I switched Docker to using Windows Containers and the Docker Engine DID start, unlike before, but I still get the same error message.

ERROR DK0006: Couldn’t download docker images.

main.log (31.3 KB)

Any help would be much appreciated.

Hello Michael @helplessduck :wave: Welcome to DevKinsta community!

Thank you for reporting this issue, I’ve never seen this error message reported here before:

[error] Error: connect ENOENT //./pipe/docker_engine

The Error DK0006 usually related to Internet connection while downloading the docker’s containers. But I don’t think that’s the case here as you mentioned your Internet download/upload speed looked good!

Just wanted to make sure that the Hyper-V has been enabled on your Windows features? As you mentioned that it was enabled in BIOS but never installed the Win10 packages . This Hyper-V must be enabled on Windows 10 Pro, as mentioned on our documentation.

You may want to double check on your Windows 10: “Control panel → Programs → Programs and Features”, then click on the “Turn Windows features on or off” , and on the Windows Features window, find the “Hyper-V” and tick the option to enable/turn it on (if it has not been checked/enabled).

After that, close DevKinsta (and Docker as well) completely, and re-open it and see if it can download the docker images?


I faced this issue on my Windows 10 Home PC. I followed the instructions available on the Docker site.

Downloading and installing the [Linux kernel update package] ( did the trick for me.

I am not sure if this would help you because you talked about HyperV.

1 Like

Hi @Venkatramani_R welcome to DevKinsta community!

Thank you for sharing the issue you had with Windows 10 Home (with WSL2) and the workaround that worked for you ! :heart: That hopefully will help other users that may have the same issue in the future! :smiley:
Michael might want to give it a try as well and see if this would help to solve the error with that docker_engine issue.

For the Windows 10 Pro though, as per our documentation , Hyper-V and Containers Windows features must be enabled.