Firefox warning related to slow interactivity and curl 7?

Q: Date/Time this occurred (Provide your time zone also)
**A:210622:0950 (eastern time)

Q: DevKinsta Version
**A:**Version 1.1.7 (

Q: OS Version
A: MacOS 11.4 (20F71)
Q: Docker Desktop Version
**A:**Version 3.4.0 (

Q: Were any error codes or messages observed? If so, what were they?
**A:**yes “mozilla_pkix_error_self_signed_cert”

I use firefox when I want a incognito user view of my localhost.

  1. What is causing the above error code?
  2. How do I fix it?
  3. How doe it relat to rapidly diminishing user experience (cur_7 / port 443) issue mentioned elsewhere?

Q: Detailed Description of the Problem

Hi @kadso Welcome to DevKinsta! I see the error provided is related to a self signed certificate, though that would be expected as DevKinsta uses self signed certificates when having HTTPS enabled. You would need to accept the self signed certificate via your browser to bypass that message though it shouldn’t impact speed at all.

A self signed certificate would function the same as a signed one, the encryption and the speed at which it is processed would be the same other than the request being stalled when your browser prompts you to accept it. Apologies if I’m missing the mark here! I’m not currently aware of any incompatibilities with a self signed certificate and cURL :eyes:

Are you able to clarify a bit further on what you’re experiencing? Is it difficulties with the self signed certificate or are you seeing something occurring for sites you have set up for HTTPS within DevKinsta?

Thanks Melissa. I missed the “accept” button. I give that a try.

We haven’t heard back from you on this topic in a while. However, if you do need further assistance you can simply start a new post here. Thank you again for using DevKinsta. Let us know if you need further assistance! :wave: