Issue with SSL: NET::ERR_CERT_INVALID(ubuntu)

I am using devKinsta 2.9.0-6037 on ubuntu 22.04.2, HTTPS does not work, gives " Your connection is not private" warning, turn off HTTPS will work. I want to use HTTPS with my local site, the error code is “NET::ERR_CERT_INVALID”, hope I can get some help in here.

Screenshot from 2023-05-05 20-42-50

Hello @Jean :wave: welcome to DevKinsta Community!

I had the same SSL/HTTPS issue before on my Ubuntu 22.04.02.
The workaround that worked for me was the following:

  1. I checked my Firefox browser was installed via snap by default, and I noticed the following sub-folder was created: ~/snap/firefox/common/.mozilla/firefox

  2. DevKinsta was looking for this sub-folder : /home/mylocaluser/.mozilla/firefox

  3. I created a symlink uder my /home/mylocaluser/ with the following command (via terminal):
    ln -s snap/firefox/common/.mozilla .mozilla

  4. Done, after that, I was able to use HTTPS (SSL) for my local sites created in DevKinsta.

You may want to check the same on your computer and see if you can apply the same?
also have you tried to access the https:// URL on FireFox browser?


Hello again @Jean

I’ve just tested on my Linux Ubuntu 22.04.02 once again this morning and noticed the same error NET::ERR_CERT_INVALID as you mentioned/provided in your screenshot when I checked on my Google Chrome browser - though previously it was working just fine with HTTPS:// URL of my .local domains using this browser - and the same local https:// URL works just fine still on my FireFox browser.

I checked further and noticed, looks like it’s due to the recent update to my Google Chrome browser ( it was updated to the 113.0.5672.63-1 version recently).

I then tested to downgrade my Google Chrome browser’s version to the previous / older version and could see the HTTPS:// local URL/domains are working again now after I downgraded to this version:
( I checked the available/previous Google Chrome stable versions here )
It also didn’t work when I tested with the newer versions: 112.0.5615.49-1 and 112.0.5615.165-1

In case you’re experiencing the same, please check your Google Chrome browser version (if you’re using version 112 or above/the latest 113 version maybe)?
If that so, you may want to try to downgrade that Google Chrome version with the following steps:

  1. Open terminal on your Linux Ubuntu computer and download the version: 111.0.5563.146-1
    with the following command line (or you can open the http URL below on your browser to download that .deb file in question):

  2. Once downloaded, on that same terminal, type this:
    sudo dpkg -i ./google-chrome-stable_111.0.5563.146-1_amd64.deb
    (you will be prompted to enter your user’s password)

  3. Once completed, you can check/verify with this command on your terminal:
    sudo dpkg-query -l "*google-chrome*"
    (it will show that version you just installed)

  4. Close your Google Chrome browser, and re-launch it.

  5. Check if you can access your local domain with https:// (and see if it’s no longer showing NET::ERR_CERT_INVALID )

Hope that helps!


Thank you so much @Agus !
I was using chrome 112.0.5615.165 (Official Build) (64-bit), so I followed your steps and downgraded my chrome to 111.0.5563.146-1, and it worked like a charm! my local site has HTTPS now and the alert is gone. And I did what you suggest on firefox, it popup said the site is not trusted because the certificate is self-signed, I click accept the risk and continue and my devkinsta site has HTTPS on firefox now. Thank you so much!

1 Like

You’re most welcome @Jean !
Glad to see it worked fine now on your end as well! :smiley:


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.