Unable to open the website from Kinsta

I am creating a mock website to develop a website locally but it is not opening the website in the browser and when I am trying to open the website using the URL I am not getting the website

Hello @Gurvak_Singh :wave: and welcome to Kinsta Community!

Could you please provide us with a screenshot of your browser when you tried to open that local site you built with DevKinsta (was there any error message or something, or was it just a blank page, etc.)?
We need more information about it, so that we can see and understand the issue in question and may help to assist you further :slight_smile:

Best regards,

That has been resolved now, I re-installed DevKinsta.

But now I am facing a new issue. When I am enabling the HTTPS for the website it is not giving me a secured connection and I have tried installing the SSL certificate as well but I am still not able to get the secured https connection. Can you please me in understanding what I am doing wrong here.

In this screenshot you can on the left I have enabled the HTTPS in DevKinsta and on the right you can see that it is not opening the website with a secured connection.

Can you please help me with this.

Thank You

Thank you for your reply :slight_smile: and I’m sorry for the late response as I don’t work on weekends.

On Linux (and most likely on Mac as well), I’ve confirmed that HTTPS of .local URLs couldn’t be accessed on Chrome browser and got that error NET::ERR_CERT_INVALID (with the most recent version/updates, while old Chrome browser’s version worked fine), however on Firefox browser those local sites could be accessed just fine (via HTTPS) - as I mentioned in the other thread here.

As I can see you’re using Edge browser on Windows.
Could you please try on different browser (FireFox perhaps) and see if you’re able to access/open that local site URL with it ?

Best regards,

I have four browsers in my pc and I tried all of them and even after enabling HTTPS in the
Kinsta it is not giving me the secure connection anywhere. I am attaching all 4 of the screenshots here.

I’ve just re-installed DevKinsta on my Windows 11 pro machine (I set the Docker Desktop with WSL based engine as I noticed you also use WSL in your DevKinsta’s SITE Path as shown in your screenshots - previously I had used it without WSL2 and didn’t have any problem accessing the local site with HTTPS )

(that’s my Docker Desktop and its General setting)

Then in DevKinsta, I tried to create a new vanilla WordPress site (6.4.1)

Once finished, I then tried to enable the HTTPS option there, and was prompted with that pop-up and I clicked Yes

then the HTTPS toggle was enabled just fine:

After that, I click on the blue button on the bottom left side - to go to the DevKinsta Settings page

There, I scrolled down and went to the “Port selector” section, and set the HTTP field to 80, and set the HTTPS field to 443 .

Then I tried to access that new created WP local site URL (with HTTPS) on my 2 browsers (Edge and Chrome) and they all were showing just fine (secured page/connection)

So far, I couldn’t replicate this HTTPS issue on my browsers. :thinking:
Perhaps you may want to check the “Port selector” section as well in your DevKinsta’s Settings page?
if they were set with different custom ports, then you may want to try with: 80 (HTTP) and 443 (HTTPS) and see if you will be able to access the local sites with HTTPS .

Best regards,