Kinsta Application not connecting to Git Repository

Hello, I have walked through the process of setting up a GitHub repository and setting up a Kinsta application. When I create a connection to the Git Repository via Kinsta, Kinsta doesn’t return the repository link, even though the connections are fine. I have been wrestling with this issue over the last few days and have tried several fixes. I have also searched the data base and google, to no avail.

Any advice would be appreciated.

Hello Zia,

Sorry to hear about this, are you able to provide us with more details or might be even better if you can contact us via MyKinsta chat where we would look at the issue and contact our developers if assistance is needed.

Where the repository link is not returned? Is the deployment finished successfully?

Thank you in advance.

Thank you. Unfortunately, I am unable to use the chat app. I have added an image where I expect to see my Git repository listed (after connecting to Git etc) but it doesn’t appear.

I have tried many fixes including revoking, uninstalling GIt connections and reinstating them as per Kinsta guidelines but to no avail.

My Git repo is set to private - I can move through the process if I select the ‘public’ option and complete all the necessary steps but again - deploys fail even though I have the correct settings in place.

Hello Zia,

Reading your message, I’m not sure if you’ve set the permissions correctly or is there an issue with failed deployment. Apologies if that’s what you meant in your previous setup, but can you please check the following:

  • Click on the field where repository should show. You should see ‘Edit GitHub permissions’ as an option. Click and log in to GitHub and check if you’ve granted Mykinta with necessary permissions.

If you’re still having difficulties after you are sure correct permissions were granted and you get deployment errors, please let me know what errors are you getting.

Kind regards

Thank you Vladimir for confirming my Git permissions are fine. When I deploy I don’t see a branch in the window in the screenshot. I also get the following error when I deploy.

May 27 18:42:25 Host key verification failed.

May 27 18:42:25 fatal: Could not read from remote repository.

May 27 18:42:25

May 27 18:42:25 Please make sure you have the correct access rights

May 27 18:42:25 and the repository exists.

It’s worth noting that I can connect directly to Git via bash and have set up SSH keys on both Kinsta and Git. So as far as I am aware, authentication should not be an issue. Thank you for your continued advice.

Hi Zia,
Thank you for your response!

That does seem to be an authentication issue somewhere.
Is this a new GitHub account by any chance?

Can you also try disconnecting and reconnecting the account again via GitHub (just to force a new setup)?
Please let us know if that changes anything.

Thank you in advance!


Hi Andre, Yes, this is a new GitHub account (a few days old now). The Git set-up was quite straight forward as was the Kinsta connection albeit the error I now receive. I have disconnected and reconnected several times in varying combinations over the last few days and got nowhere. Assuming I have done this correctly.

A point to note is that I can connect fine to Git using Terminal / SSH connection so it seems I can authenticate on Git to my repo.

I have again revoked all accesses and removed the Git connection. Reconnected everything but got the same error. The Git repo is set to private.

Hi there @Order66 :wave:

Thank you for your reply and confirmation! :smile:
The issue here seems to be with your new GitHub account, that might has been created less than 3 days ago. For security reason, the Git account creation date must be more than 3 days, otherwise, users won’t be able to authorize their GitHub account.

If users attempt to authorize their account earlier than 3 days, by default, there will be a restriction for that, and they won’t be able to authenticate later (and our support team will need to remove that restriction manually from our end).

To check it further and to remove this restriction, could you please provide us:

  1. Your GitHub username
  2. Your MyKinsta company ID
    (that can be found when you access the Applications page at - please let us know random characters after the idCompany= )

Once we have the above information, we will be happy to assist you!

Best regards,
Agus Utomo

Hi @Agus I have sent this to you via DM. Please let me know once done.

Hello @Order66

Agus is not in at the moment, can you send it to me in DM?

Kind regards

Hi There - DM has been sent to you.

Hello :wave:

I reviewed the messages in DM. We’re still looking into this. It might take a while and I appreciate your patience.

Kind regards

@Order66 :wave:

Just wanted to let you know that we’ve unblocked your GitHub user. You’re all set to deploy your application from your GitHub repository, and it should work smoothly this time. Cheers!

Thank you everyone for your support - the problem is resolved. So if your Git account is less than 3 days old, any connection attempts (via Kinsta) will fail. So in future, it is best to wait 3 days before initiating a connection. If you find yourself in the same position as mine, you need to contact Kinsta support who will unblock your connection.

@Kinsta Support - I couldn’t find any definitive answer before this so perhaps it is worth making a note for users during set up.

Thanks again.

You’re most welcome @Order66 ! :bowing_man: glad to hear the problem has been resolved now!

About that Git account that has been created less than 3 days, we have this public documentation which mentions about that:

(that’s why previously I mentioned the same and asked for your GitHub username and whatnot :smile: - hope that clarifies!)

Best regards,
Agus Utomo

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.