"Something bad happened" when pulling site from Kinsta

Q: Date/Time this occurred (Provide your time zone also)
A: Dec 23

Q: DevKinsta Version

Q: OS Version
A: MacOS Monterey

Q: Docker Desktop Version
A: 4.15.0 (93002)

Q: Were any error codes or messages observed? If so, what were they?
A: "Something bad happened.

Q: Detailed Description of the Problem
A: When attempting to pull down a site using DevKinsta, it fails after “Configuring NGINX” (screenshot of UI: Image 2022-12-23 at 1.23.45 PM). I checked the log files for the app, and it appears to be failing to connect docker. I have tried fresh installs of DevKinsta (including removing the directories recommended in the uninstall guide), and fresh installs of docker, and the docker images to no avail. I have also tried pulling down the live site, instead of the staging site, but have the same issue.

Here’s what is in the logfile:
[2022-12-23 13:26:46.944] [info] [containerExec] Command ‘cd /www/kinsta/public/clubadventures && wp --allow-root --skip-themes --skip-plugins core version’ on devkinsta_fpm finished with exit code 1
user: ‘root’,
[2022-12-23 13:26:46.982] [info] [containerExec] Command ‘cd public/clubadventures && wp --allow-root --skip-themes --skip-plugins db size --size_format=b --url=http://clubadventures.local’ on devkinsta_fpm finished with exit code 1
[2022-12-23 13:26:47.011] [info] [containerExec] Command ‘mysql -u root -p****** -e “create database Club_Adventures;”’ on devkinsta_db finished with exit code 1
[2022-12-23 13:26:47.011] [error] [ipcMainStep] Error in operation SITE_CREATION, step database: Error: Error (1): UERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

Hey @Brian_Burkett,

Let’s check if we are able to create a test database manually. First, let’s find the MySQL root password by opening the app Terminal of your mac and using the following command:

docker inspect devkinsta_db 2>&1 | grep MYSQL_ROOT_PASSWORD

Then, open Docker, press the tree buttons menu in the same line of devkinsta_db, and click on open Terminal. Once there, use the following command, being sure to update YOURPASSWORD with the value you got from previous command:

mysql -u root -pYOURPASSWORD -e "CREATE DATABASE Club_Adventures_Test;"

Do you get any errors?