Static Site missing button when add domain

Hi there,
Deployment from wordpress with kinsta domain,everything okay. pls see here . But afier add domain, also could visit,but found missing order button,pls click here,Pls let me know how to fix it,thanks.

Hello @freeman6789

I have checked your static site and I see that the button is there on default Kinsta domain, but not there on your custom domain.

The sites look a bit different and it seems you are using your own Cloudflare account so you need to check the following:

  1. There seems to be a GeoIP restriction applied and it might be affecting the Stripe button, since it’s loading as an iFrame
  2. It is possible that your Cloudflare account has other rules, caching or static page-related that are affecting this.

To confirm it’s up to your personal Cloudflare account, try pausing Cloudflare for this subdomain and then close all incognito tabs and open a new one, then load the site with your custom domain and check if the button is there.

Kind regards

thanks for yr reply.
already disable as screen shot,but still couldn’t the button.

Hi @freeman6789 :wave:

After looking into the matter, the issue doesn’t seem to be server side related. I have checked and confirmed that your custom subdomain ( is correctly mapped to your static site. You can see for yourself that a sample image can be loaded on both the default domain and your custom subdomain.

As Vladirmir suggested earlier, it’s possible that the issue lies within your own Cloudflare account. To better understand and resolve the issue, it may be best to temporarily set your Cloudflare account to DNS Only from Proxied and see if it fixes the issue.

Let me know how it goes!

Yup Adrian, u right when DNS only, thank you very much.

Hi @freeman6789,

You are most welcome. We are glad that we’ve helped you fixed the missing button. I assume this is already resolved, right?

If ever you encounter issues, please feel free to reach out.

Have a great day!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.