Cannot open pulled Kinsta site in local in browser - The Site cannot be reached

Q: Date/Time this occurred (Provide your time zone also)

Q: DevKinsta Version
A: newest version. Just installed it today

Q: OS Version
A: Windows 11

Q: Docker Desktop Version
A: newest version. Just installed it today

Q: Were any error codes or messages observed? If so, what were they?
**A: Seems no ip address is mapped to the local url **

Q: Detailed Description of the Problem

Hi there. Can anyone tell me what I’m missing? I just install Devkinsta tool and pulled one of my Kinsta site to local. The pulling process looks fine. I can open database from devKinsta, but I cannot open the site.

I think I found the solution. The devKinsta did not add necessary record into host file.
I deleted the site and add it back from kinsta, this time it worked. The host record was added. I don’t know why it was not add in the first time.

Hi @mbird1981, Welcome to the Kinsta community!

I am sorry to hear that you had issues with DevKinsta. This is strange behavior. It could be that something is blocking the changes to your host file initially. I am happy to know that deleting and adding back the site resolved the issue.

Can you send me a copy of your main.log file through direct message? You can find it by clicking on the question mark (?) icon at the bottom left corner of DevKinsta, and then selecting “Reveal log file in File Manager”. I would like to take a look at it and see what caused it.

Looking forward to your update.

HI @merineth ,
Attaching the log file here.
main.log (759.6 KB)

Thanks for the replying.

Hi @merineth ,
There is a new issue occurs to me. I cannot push my local updates to the live site in Kinsta.
I click the “Sync” button, chose"Push to Kinsta", it redirects me my sites list in Kinsta, but I cannot choose anyone and there is no button in this interface. What shall I do?

Hi @mbird1981 ,

It looks like there was an issue with the highlighted “Test Environment” site (I’ve moved the screenshot so that it’s no longer publicly displayed). The environment was blocked due to a previous action that had taken place on the site.

That environment has now been unblocked, if you restart DevKinsta, you should see a “Create new environment” option under the site.

You will need to create a new Staging environment in order to push the local site to Kinsta: WordPress Hosting - Staging Environments - Kinsta® Docs

Once the Staging environment is created, you should be able to then locate that Staging environment in the list of sites to push to, within DevKinsta.

If you do run into any other issues, please let us know.

Hi @jackirish
I restarted DevKinsta, there is still the same. “Creat new environment” option does not appear under the site name.
And I found that many of my sites does not have this option either. Please check the screenshot and remove it later:
If I want to set staging environment for these sites, Do I need to ask you “unlock” them one by one?

Hello @mbird1981,

I am here to assist you. I wanted to clarify that if you have a Company Developer role, you have the ability to create and delete DevKinsta sites. You can also push and pull sites to and from existing staging sites at Kinsta. However, you won’t see the option to “Create a new Environment” within the Push action in the app.

If you still prefer to have the “Create a new Environment” link in the app, you can request any Company Admin or Company Owner of the respective accounts to elevate your user to Company Admin. This will allow you to see the option to “Create a new Environment” link in the app.

Alternatively, if you need to create a new Kinsta site, you can simply log in directly to MyKinsta and create the site from there.

I hope this information helps to clarify things for you. :slightly_smiling_face:

So this is because I dont have the company admin role to create Staging environment.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.