Local site won't open?


Out of nowhere today (haven’t made any changes at all), I can’t open my local site anymore. It will say the site is running in DevKinsta, and the docker containers are running as well, but the browser won’t load the page.

I tried also accessing directly through docker, but that doesn’t work either. It’s like the container is either somehow damaged or the path is not syncing…

I of course already tried stopping the service, restarting my system etc., but nothing works.

Would appreciate inputs

Might not be the same “fix”, but I had a similar issue last week when pulling my sites. My issue was related to using WordFence, and there being a line in the user.ini file requiring it at the production site URL. Deleting that file/line fixed the issue for me.

Could be worth renaming the user.ini file to user.ini.bak as a quick test to see if that allows the site to run properly.

Thanks. Unfortunately doesn’t work :frowning:

I had to simply duplicate the theme content to a new site, now it works…

Hi @emilb, I am sorry to hear that you are having issues with your local site not opening.

Usually, the local site should load without a custom port. Based on your screenshot it has the custom port on the URL. Can you please check that the “Auto Detect” port selector option in DevKinsta is unchecked and the default ports 80 and 443 are set respectively. See screenshot below:

I hope this will help you out and let me know if you still encounter similar issue in the future.
Though I am glad your local site works after duplicating the theme content.

Have a great day!