Time to move on from DevKinsta

I wanted to love this software so much, but I just can’t waste my time on it anymore. Seems like no matter what you try to do with it, you’ll run into endless errors with no real documentation on what’s going on.

Containers not starting
Port configurations all out of whack
Downloading randomly stops and restarts
The list goes on

I know the adoption rate on this software is low, but it could really be a powerful tool for Kinsta to offer with their web hosting. Assuming they figure out the bugs, which I’m not holding by breath, they need to figure out the site download/upload speed issues. A 20Gb site shouldn’t take 6 hours to download on a gigabit internet connection. Either make developing on your platform as friendly as you can or stop offering the software all together. I really held my tongue for as long as I could, but I feel like developers should be aware of the glaring issues with DevKinsta before investing too much time and energy into it.

Hello Justin @coloradodev :wave:

Thank you for the report and feedback, and for sharing your experiences using this DevKinsta software.
I’m sorry to hear that you’ve been run into endless errors with it.

Regarding the containers not starting, if you’re still experiencing this, I would suggest to try to close the Docker Desktop as well as to close and quite the DevKinsta completely, and then re-open them and see if the containers in the docker can be started. Also, I’m not sure if you’re running the latest DevKinsta version 2.9.0, if you haven’t upgraded it, please also give it a try.

Regarding the port configuration, I’m not sure what’s the exact issue you’ve been experiencing with it, but by default DevKinsta normally will use/setup these ports HTTP = 80, and HTTPS = 443 . These can be customized/changed in DevKinsta → Settings → Port Selector section (in case any of those default ports have been used by other web services running locally on the user’s end/side).

Regarding the downloading (WP Site from Kinsta) that’s randomly stops and restarts, there might be some information of the error that would be logged in the main.log file.
Based on the previous posts you made, it seems you’re using DevKinsta on Windows 10 pro with WSL2 . On Windows, the main.log file can be found here:
(I myself on Linux, and that main.log file can be found here: /home/yourusername/.config/DevKinsta/logs )
If you’re still experiencing this issue, please privately send me your recent main.log file and see if I can find anything from it.

For the download/upload speed issue (with huge site transfers, 20GB site that took 6 hours to download on a gigabit internet connection), I’m not really sure what might be causing that, but I will relay this case to our internal DevKinsta developers and see if they can check/investigate further.

The only issue I’ve seen is with the “DK0065 error” when pushing/uploading huge/large local site to Staging on Kinsta server, like this case that was reported before (and was solved) due to large directories and files (large .zip backup files and whatnot)
Note: the upload process is using rsync to share files with the remote site.


I initially installed DevKinsta and Docker and all appeared to work well. For a few days stopping and restarting it was okay but then I started getting the the error where devkinsta nginx keeps restarting in Docker. Now, no matter what I do, the nginx keeps restarting.

Hey @spookyac47,
Welcome to the DevKinsta community!
We’d like to look into this issue further, can you please open a new thread and share more details about the issues you are experiencing?



Greetings Alessandro. I will enclose three images, one being the DevKinsta screenshot with the DK0005 error message. The second is a Docker screenshot showing the kinsta/devkinsta_nginx:1.2.9 container with the Restarting message. If I click the arrow to restart the container, it starts the process but returns to the restarting text. I have tried starting Docker prior to starting DevKinsta but the results are the same. I am not great at troubleshooting system level problems. I tried updating my Windows 10 Pro OS and that was successful. I’m a stubborn person and will keep trying things to get the DevKinsta/Docker setup working but would appreciate a bit of assistance. Thank You

Thank you very much for the details @spookyac47 . I don’t see the screenshots as attachments but we can try this:

  1. Close DevKinsta and be sure it’s entirely closed and not just minimised
  2. Open Docker
  3. Delete all the devkinsta containers by clicking on the bin icon
  4. Start DevKinsta again

While in Docker, be sure to delete only the containers and nothing more, by doing so there will be no data loss.