Windows 10: updating themes/plugins requires FTP creds

Hi all :wave: While we haven’t been able to duplicate this at the moment so far we feel this may be permission related, if anyone continues to see that prompt beyond the wp-config.php edit (perhaps @nametags4u ) may we please have you try running the following command?

docker exec devkinsta_fpm chown -R www-data:www-data /www/kinsta/public/

If the issue persists beyond that may we have the output of the following:

On DevKinsta (Docker):
docker exec devkinsta_fpm ls -al /www/kinsta/public/
docker exec devkinsta_fpm ls -al /www/kinsta/public/SITE_NAME/

On Windows (Command Prompt):
icacls C:\Users\USER\DevKinsta\public
icacls C:\Users\USER\DevKinsta\SITE_NAME

Thank you! Hopefully this helps pinpoint what might being on there for anyone still having difficulties!

Thanks Melissa,

I’m getting ready to try your suggestions… In the meantime, it didn’t dawn on me before, but I get Security Warnings every time I launch a site from DevKinsta. I always accept the risk. That may be why I can’t run updates.

This is the specific warning I get. Note that I do not get this warning when using Desktop Server, Laragon, or Local by Flywheel.

Warning: Potential Security Risk Ahead
Firefox detected a potential security threat and did not continue to blanksite-1.local. If you visit this site, attackers could try to steal information like your passwords, emails, or credit card details.
Learn more…

You’re welcome! I don’t believe that would cause it, as that should only relate to how your browser is validating the SSL with the local domain :thinking: Are you able to share what version of Firefox you’re using? Is the same warning triggered on other browsers? I’ll check with our team about this as well as I haven’t been able to find much on this myself, I’ll keep you updated!

Thanks again, Melissa.

I deleted the local site and downloaded a fresh copy via DevKinsta. There are a couple dynamics in play. We have a new IT provider that locked me down so tight I couldn’t research military or law enforcement. That’s 90% of our business. So they opened up the firewall, I downloaded a fresh copy of the website, and ran the docker exec devkinsta_fpm chown -R www-data:www-data /www/kinsta/public/ code you sent. One or all of those combined seem to have fixed the problem.

Now all Kinsta has to do is make the thing lightning fast. I’m using SSDs, but it’s still slower than working online. This will be a great time saver once it’s optimized.



Hi @melissa

I am new to Devkinsta & Docker, can you please explain where & how to execute this docker command?

I tried it in devkinsta_fpm CLI, but ended up like this. Can you please help me on this?

Note: On Windows side the permission is all ok. I have pasted the response below.

C:\WINDOWS\system32>icacls C:\Users\saravanakumar.s\DevKinsta\public
C:\Users\saravanakumar.s\DevKinsta\public Everyone:(OI)(CI)(F)

Successfully processed 1 files; Failed processing 0 files

Hi @Saravana_Kumar ! Welcome to DevKinsta :slight_smile: . Do you have Docker installed? The docker commands are run inside your shell/Terminal of choice.

Thanks @michael Yes, docker installed in my machine. I have used the Windows Command Prompt, and execute those ownership changes command.

Its working now.

A post was split to a new topic: Enabling cron job

Is what i found this morning as I attempted to update plugins.

I’m running MacOs 11.23, DevKinsta 1.1.5 (1559), Desktop Docker 3.3.0 (62916).

This is the first time " Connection Information

To perform the requested action, WordPress needs to access your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host."

has shown up.

Please advise…

P.S. I’m a non-programer so please be explicit with any coding request. Thanks.

Hi @kadso . I’m sorry to hear you’re having trouble! I’ve merged your topic into another thread as it’s related to the same bug/issue others are experiencing. There are a few solutions posted above. The easiest being adding the following into your wp-config.php file


Try that first and let us know if it works.

I have tried adding this but to no luck. I am having the same issue, it’s not afresh install but a pretty raw install. It’s our starter theme. Copied the site on Kinsta host, downloaded on dev kinsta. Then I got that same FTP request for credentials to do any updates at all. Then when I tried to upload an image it wouldn’t let me do that either.

Gave the following error message:
The uploaded file could not be moved to wp-content/uploads/2021/05.

Additionally when I tried the define('FS… I got a bunch of errors in my log.

2021/05/08 05:32:26 [error] 26#26: *584 FastCGI sent in stderr: “PHP message: PHP Warning: Use of undefined constant ‘FS_METHOD’ - assumed ‘‘FS_METHOD’’ (this will throw an Error in a future version of PHP) in /www/kinsta/public/websiteurl/wp-config.php on line 67PHP message: PHP Warning: Use of undefined constant ‘direct’ - assumed ‘‘direct’’ (this will throw an Error in a future version of PHP) in /www/kinsta/public/websiteurl/wp-config.php on line 67” while reading response header from upstream, client:, server: websiteurl.local, request: “POST /wp-admin/admin-ajax.php HTTP/2.0”, upstream: “fastcgi://”, host: “websiteurl.local”, referrer: “https://websiteurl.local/wp-admin/customize.php?return=%2Fwp-admin%2Fupdate-core.php”

EDIT: All of my websites are doing this. Nothing will let me upload or update plugins. It’s like my whole wp-content folder is just editable.

You can’t even delete plugins.

EDIT: 30m later -

This fixed it. I ran this, it took a bit to execute. Though when it did I was able to update, upload, and good to go. Opened up command console, copy, paste, good to go

1 Like

As a follow up to this I have had to do this multiple times now. A new website installed didn’t want to work either and ran this and I was fine again.

@Andrew_Fair Appreciate the update! Did you have to do this with each new install, or has it be a reoccurring issue on the same site?

Thank you - that did the trick for me too!

I just tested this and yes, looks like every time I have downloaded a new website from Kinsta it doesn’t give me permission to do so. Funny enough, I’m back on this post today because I needed that again to run so I could make updates to an existing client.

Hey Michael,

This does appear to be an ongoing issue. I have to run this everytime I pull a site from Kinsta and my employees are having to do it too. Is there a better resolution in sight?

We simply run

each time but I feel it’s an unneeded step.

Looking forward to continued improvements of DevKinsta!

@Andrew_Fair I’m sorry for the trouble. I understand that’s not convenient at all. I’ll provide an update here as soon as I have more to share.

Sounds good, Thank you Michael, overall I am happy with DevKinsta but certainly excited to see more features/updates :slight_smile:

With the release of DevKinsta 2.0, this issue should now be solved. You can download DevKinsta 2.0+ here. Let us know if you continue to see this issue!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.