WordPress Installation Folder Is Empty After Creating New Site

Running Windows 11
Running Docker: 4.20.1
Running DevKinsta: 2.11.0

Just uninstalled DevKinsta and Docker.
Reinstalled DevKinsta
Reinstalled Docker (natively, not through DevKinsta)
I did NOT perform “clean” uninstalls.

It found my sites and displays them in DevKinsta, but none of their databases are in Adminer (sad). Not sure if I can get them back, but that’s another topic.

When I go to create a new site, it finishes the process, but the folder is empty (no WordPress files in the folder, but DevKinsta does create the folder.

I have the latest version of WordPress (6.2.2) in the following folder: c:\users[me]\AppData\Roaming\DevKinsta\wp\wordpress-6.2.2\

But to no avail, every time I try to create a new site, the folder is empty. DevKinsta does not display any errors through the process.

Since the folder is empty, I get Error 403 / nginx when I try to open site.

The only way I am able to run a local WP site is to create one in real kinsta and then sync it.

Hello @Chevas ,

I don’t think you should uninstall Docker (and DevKinsta), and could just install their new version to replace the old ones. As I recall when the Docker is uninstalled, the container/images and its data would/might be removed (and that might be the reason why none of your sites’ database are not listed in the Adminer) :cry:

Anyway regarding the initial issue you reported, looks like I was able to find the issue (tested on my Windows 10 pro machine) with the same Docker version (4.20.1) and DevKinsta 2.11.0 version.
Though I only upgraded both DevKinsta (from 2.10.0 to 2.11.0) and Docker Desktop (from the previous version to 4.20.1) without uninstalled them.
After that, when I launched DevKinsta and tried to add a new WP site, I got the same issue as you reported (empty site’s folder and no data/tables were created in that site’s DB for that new site, and when I launched it I got 403 error/NGINX).

I then checked my folder:
and there I noticed somehow the latest WordPress (version 6.2.2) was extracted under the sub-folder named as wordpress (instead of wordpress-6.2.2)

I went ahead and renamed that wordpress folder to: wordpress-6.2.2

then I deleted that new WP site created before in DevKinsta, and re-created a new WP site, and this time the new WP site (6.2.2) could be created just fine.

I would suggest to check the same on your local windows folder/subfolder and try to rename that wordpress to be: wordpress-6.2.2

It should be located under the:
(similar to what’s shown in the above screenshot I shared).

instead of under the:


Hi Agus,

This was my exact folder structure when I first experienced the problem:

As you can see above, I had the correct folder name: \wordpress-6.2.2

I went ahead and created the folders you see in the red box:

And then I attempted to “Add Site”. I left both folder structures in place with the latest version of WordPress in both locations:


It’s still not installing correctly.

Maybe DevKinsta is installed inside of AppData\Roaming\DevKinsta for me because I chose to install “just for me, one user” and not “all users on this computer” ? I don’t know.

Thank you for your reply and update! :slight_smile:

I’ve just tried the same (once again) on my other machine/mini-pc (that runs on Windows 11 pro), there I upgraded / re-installed DevKinsta 2.11.0 (was 2.10.0 version) and chose to re-install “Only for me”:

Screenshot from 2023-06-09 10-42-36

also then I upgraded the Docker Desktop to the latest version (4.20.1).

And as I could check, there was no /wp sub-folder created under my:
C:\Users\my username\AppData\Roaming\DevKinsta

Then I launched DevKinsta (2.11.0) and created a new WP site, and could see it downloaded the WP (6.2.2) and extracted it properly with the folder name as wordpress-6.2.2 under this sub-folder:
C:\Users\my username\DevKinsta\wp\

the new WP site could be created just fine as well there:

I still couldn’t replicate the reported issue in question on my Windows 11 pro machine either.

Also, just wanted to add that previously I was prompted to add/accept the following paths (to share these) in the Docker:

C:\Users\my username\DevKinsta\wp
C:\Users\my username\DevKinsta\temp

(You may want to check your Docker Desktop → Settings → Resources → File sharing, and add yours, e.g.: C:\Users\Chevas\DevKinsta\wp and C:\Users\Chevas\DevKinsta\temp , if they have not been added there)

If still no luck, perhaps you may want to try to re-install once again, and see if when adding new site, it would download the .zip file and extract it (as wordpress-6.2.2) under your sub-folder:
and if the new site can be accessed properly after that.


I clean uninstalled everything.

Installed DevKinsta (latest version).

When it got to the docker portion, it prompted me to download Docker. I clicked to download from within the DevKinsta App, mainly to see if the flow would work, but it failed (can’t remember error).

Installed Docker manually, with the DevKinsta installation window open where the “Retry” button displays.

Once Docker was fully installed, clicked “Retry” and then the DevKinsta installation window just displayed the error message “errors” (that was the totality of the error message).

Had to Close DevKinsta via task manager.

Clean uninstalled DevKinsta again.

Then I installed a previous version of DevKinsta (downloaded on April 18, 2023).

Made sure to “share” every time Windows 11 prompted to share (which I always did in the past).

DevKinsta installed okay this time, but to be fair, this time Docker was already installed before I attempted to install DevKinsta.

Created a test site, everything worked.

Closed everything down.

Installed the latest version of DevKinsta (2.11.0). The installation window detected a previous version of DevKinsta and said it would “install/upgrade”. So I proceeded and it succeeded.

Created a test site and it worked again.

So, not sure what all of that did, but I’m good now.

Any time DevKinsta tells me there’s an update, I get concerned. I wish that wasn’t the case. In the future, I will have to export all the databases and copy the folders to back the websites up. Thankfully I can get most websites synced from my Kinsta account.

1 Like

Thank you for the update @Chevas :slight_smile:
Glad to hear everything worked properly again now on your end!
Yeah, sounds a great plan! It’s always better to backup your sites (files and database) just in case, then you may perform with the upgrades/updates! :+1:

I will mark this case/topic as resolved/closed then!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.