Cannot Run DevKinsta Without Root Docker


I have spent about 6 hours trying to install DevKinsta on a ubuntu instance and it keeps going in circles.

The issue I am running into is DevKinsta is always trying to use the root docker instance, even if it is not installed. If I completely remove DevKinsta, and docker desktop, and any other docker components, when I get to the point where I am installing DevKinsta it still wants root.

I know this because I run the application and it immediately pops up an authentication window looking for my root user (ubuntu) because it wants to start docker. If I run dev-kinsta from the command line I can see in the logs that ‘unix:///var/run/docker.sock’ isn’t running. (Of course its not, docker is not installed).

The only way I have been able to get this to work is doing a soft link pointing /var/run/docker.sock → ~/.docker/desktop/docker.sock, which is of course quite a hack. Having said that, the application still keeps asking me for the root’s password as it goes along while doing a pull, only to have “Something bad happen” pulling a site.

20:58:09.145 › [ipcMainStep] Error in operation SITE_CREATION, step rsync: Error: Encountered an error in child process 20536: 125. docker: Error response from daemon: Conflict. The container name “/devkinsta_create_import_126f90459e5d480ead15a7c59de97dcc” is already in use by container “57e6b8fe967008514dd6604568371bd13206ea20d46992199d023fef092d2a5e”. You have to remove (or rename) that container to be able to reuse that name.

Any thoughts on why the application is so hell bent on getting root access? (I assume that this is a symptom of something else).

Mike C

Hello @sleadership Mike :wave: , Welcome to DevKinsta community!

I myself also use Linux Ubuntu (22.04.2 LTS currently) and only installed Docker Engine (without Docker Desktop) and I’ve been able to use DevKinsta just fine.

From my linux terminal, if run this: docker context list
I would get the following:

Both paths to that “docker.sock” look like these on my computer:

agus@Lenovo-IdeaPad-FLEX-15IWL:~$ ll /var/run/docker.sock
srw-rw---- 1 root docker 0 Mei 8 09:30 /var/run/docker.sock=

agus@Lenovo-IdeaPad-FLEX-15IWL:~$ ll ~/.docker/desktop/docker.sock
srwxrwxr-x 1 agus agus 0 Feb 11 21:26 /home/agus/.docker/desktop/docker.sock=

Each time I open/launch DevKinsta, it would ask me to enter the password of my Linux user account:

and once I entered my user’s password, DevKinsta would open just fine and I could use it to create local site(s) and run the site(s) properly - and no errors.

Perhaps you may want to try to first un-link that /var/run/docker.sock → ~/.docker/desktop/docker.sock

then please run this command line:

docker context list

and please see if the asterisk (*) is shown next to the “desktop-linux” instead of next to the “default” - similar to the screenshot I provided above ?
If that so, please try to run this command line (to switch the context to Docker Engine):

docker context use default

If it’s still does not work, I would suggest to try to remove/uninstall both DevKinsta and Docker Desktop and try to install Docker Engine only and re-install DevKinsta - and see if that will work fine (which worked for me).

Hope that helps! :crossed_fingers:



I did what you recommended. I installed docker.
sudo apt install

I then changed context back to default.
docker context use default

I also then stopped and deleted containers in both contexts. And then loaded dev-kinsta.

I keep running into the issue where dev-kinsta is getting a permission denied when trying to edit the wp-config. The reason is because the application is running in a mixed user mode. (root and my user). The containers are running as root, and the app is running as my user.

In order to move forward I have to recursive chmod the DevKinsta directory. (each and every time i do a pull/sync).

I’ll note this causes later issues when I try to upload things, like plugins and the container can no longer write to the disk because its my user’s directory.

I’d assume for this to work smoothly either the entire process should be run as ubuntu (the super user), or everything (including docker) should be run as my user. (docker-desktop).


Thank you for your reply and update Mike!

As I remember, I didn’t install Docker engine with and I only followed the instructions provided there .
That name seems to be an older version of Docker as mentioned on that page?
Maybe you may want to try to uninstall that old one and setup / re-install docker engine from Docker’s apt repository.

Here’s what I have installed on my Linux Ubuntu:

agus@Lenovo-IdeaPad-FLEX-15IWL:~$ apt list --installed | grep “docker|containerd”

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.,now 1.6.21-1 amd64 [installed]
docker-buildx-plugin/jammy,now 0.10.4-1~ubuntu.22.04~jammy amd64 [installed]
docker-ce-cli/jammy,now 5:23.0.6-1~ubuntu.22.04~jammy amd64 [installed]
docker-ce-rootless-extras/jammy,now 5:23.0.6-1~ubuntu.22.04~jammy amd64 [installed,automatic]
docker-ce/jammy,now 5:23.0.6-1~ubuntu.22.04~jammy amd64 [installed]
docker-compose-plugin/jammy,now 2.17.3-1~ubuntu.22.04~jammy amd64 [installed]
docker-scan-plugin/jammy,now 0.23.0~ubuntu-jammy amd64 [installed,auto-removable]

When you launched DevKinsta, were you asked to enter the password for your Linux user account to run “/bin/bash” as the super user (as shown in the screenshot I sent you previously)?
And just to clarify my linux user account (agus) has sudo rights (part of the sudo group). Your linux user account has sudo rights as well right?

Also as I can see, my ~/DevKinsta folder and the ~/DevKinsta/public/ sub-folder have “root:root” user/group access, while the site’s sub-folders and its files have “agus:agus” user/group access (with 0777 permission) and I’ve never altered/changed them manually (and have been able to create new sites as well as import sites from my MyKinsta account just fine).

Here are screenshots of how my DevKinsta and its sub-folders/files look like:

and screenshots showing the DevKinsta and docker processes run (in mixed user mode, my linux user and root as well):