Can't add certificate to Keychain - DK0023

Hi! I’ve successfully installed DevKinsta to MacOS Big Sur, I’ve tried to pull one of my kinsta sites into local, but at the end of the pull, it shows the error “DK0023”.
I’ve looked after that problem, but I didn’t find anything useful.
Do you guys have some tips, what could be the problem?

Welcome to DevKinsta @Krisztian !

When pulling a site into DevKinsta, you should have been prompted by MacOS to add the certificate. It may be worth trying that again. If it continues to fail, try creating a new site right on DevKinsta to see if that works. There may be something blocking it on your MacOS. Perhaps any applications that could be closed to see if that helps?

Hi @michael , thanks for your advice!
I’ve reinstalled my site, but still dying on the last bullet with the error code: DK0023
After multiple restarts I’ve closed every app except docker and KinstaDev.

@Krisztian Let’s try the these two things:

Could you tell me if it occurs on a brand new site?

If it does, could you please try uninstalling and reinstalling DevKinsta?

Hey Michael -
I am experiencing the same issues here. This issue has happened when creating a new site, and when importing a site from Kinsta. Any help would be greatly appreciated.

I have tried a couple of things so far. Restarting DevKinsta, Docker, etc. The keys have been created and added to my Keychain. However, DevKinsta is still saying that the certificate can not be added to the Keychain. This is preventing the import process from Kinsta from finalizing, thus preventing local access to the imported site.

1 Like

Yes, I’m having this exact problem as well. I tried installing the version of Docker that comes with Devkinsta instead of updating it. That also makes no difference.

This problem did not yet occur a couple of months ago. I downloaded and worked with my “live” site locally without any problems. Now the installation does not finalize as described above.

Hi, Im having the same issue. i also cant change the toggle on devkinsta either.

Hi @shakeygapplications @Rob_Veugelaers @will_chem . Welcome to DevKinsta! I’m sorry for the issues you’re experiencing here with it. We’re looking at what could be happening here.

One level up from where DevKinsta installs the WordPress files, there should be a directory called ssl/. Could you try fully deleting all the certificates in that directory and see if it lets you recreate them when relaunching DevKinsta?

Hi it made no difference. It wont let me re create them.

I have to agree with @will_chem. Deleted the SSL records, no change!

I did update Big Sur last week I think… maybe that has something to do with this?

Same results as @will_chem and @Rob_Veugelaers

A little more context… after removing the ssl directory, I restarted DevKinsta and DevKinsta was able to create the ssl directory. However the SSL Update Failed within DevKinsta. DevKinsta and Docker has Full Disk Access on my Mac. Highly unlikely this is a permissions issue.

Thank you everyone for testing that. I’m sorry again for the trouble here. We’re currently reviewing this and will post an update here as soon as we have more to share.

Hi i was wondering if there was any update on this yet. We thought we had the perfect solution in Kinsta.


Nothing yet? Problem still persists also after the latest update.

@will_chem @Rob_Veugelaers I’m very sorry for the wait here. I’m afraid I don’t have an update to provide yet on this but will certainly post here as soon as we have an update on this.

1 Like

Devkinsta 2.0 seems to have solved the issue!

1 Like

We believe since DevKinsta 2.0 and a few of the updates that came after that should have resolved this issue here. If you continue to have issues here however, please do let us know by creating a new post here. You can download the latest version of DevKinsta here.