Devkinsta_adminer database Warnigns make GUI unreadable

Q: Date/Time this occurred (Provide your time zone also)
**A: I first noticed this in February or March 2024

Q: DevKinsta Version
**A: 2.13.2.8698

Q: OS Version
**A: Mac OS Sonoma 14.4.1

Q: Docker Desktop Version
**A: 4.28.0

Q: Were any error codes or messages observed? If so, what were they?
**A: Yes: Warning : Trying to access array offset on null in /var/www/html/adminer.php on line 1179
also:
Warning : Trying to access array offset on null in /var/www/html/adminer.php on line 1777

within docker adminer this line 1777:

as$he=>$W)$A.=where_link($t++,$he,$W);}$X=select_value($X,$A,$o,$fi);$u=h("val[$Hi][".bracket_escape($z)."]");$Y=$_POST["val"][$Hi][bracket_escape($z)];$tc=!is_array($J[$z])&&is_utf8($X)&&$K[$Xe][$z]==$J[$z]&&!$pd[$z];$ei=preg_match('~text|lob~',$o["type"]);echo"<td id='$u'";if(($_GET["modify"]&&$tc)||$Y!==null){$xd=h($Y!==null?$Y:$J[$z]);echo">".($ei?"<textarea name='$u' cols='30' rows='".(substr_count($J[$z],"\n")+1)."'>$xd</textarea>":"<input name='$u' value='$xd' size='$xe[$z]'>");}else{$Ae=strpos($X,"<i>…</i>");echo" data-text='".($Ae?2:($ei?1:0))."'".($tc?"":" data-warning='".h(lang(257))."'").">$X</td>";}}}if($Pa)echo"<td>";$b->backwardKeysPrint($Pa,$K[$Xe]);echo"</tr>\n";}if(is_ajax())exit;echo"</table>\n","</div>\n";}if(!is_ajax()){if($K||$E){$Ic=true;if($_GET["page"]!="last"){if($_==""||(count($K)<$_&&($K||!$E)))$md=($E?$E*$_:0)+count($K);elseif($y!="sql"||!$ce){$md=($ce?false:found_rows($R,$Z));if($md<max(1e4,2*($E+1)*$_))$md=reset(slow_query(count_rows($a,$Z,$ce,$sd)));else$Ic=false;}}$Pf=($_!=""&&($md===false||$md>$_||$E));if($Pf){echo(($md===false?count($K)+1:$md-$E*$_)>$_?'<p><a href="'.h(remove_from_uri("page")."&page=".($E+1)).'" class="loadmore">'.lang(258).'</a>'.script("qsl('a').onclick = partial(selectLoadMore, ".(+$_).", '".lang(259)."…');",""):''),"\n";}}echo"<div class='footer'><div>\n";if($K||$E){if($Pf){$Ie=($md===false?$E+(count($K)>=$_?2:1):floor(($md-1)/$_));echo"<fieldset>";if($y!="simpledb"){echo"<legend><a href='".h(remove_from_uri("page"))."'>".lang(260)."</a></legend>",script("qsl('a').onclick = function () { pageClick(this.href, +prompt('".lang(260)."', '".($E+1)."')); return false; };"),pagination(0,$E).($E>5?" …":"");for($t=max(1,$E-4);$t<min($Ie,$E+5);$t++)echo

Q: Detailed Description of the Problem
**A: When I view adminer db and I click to view a table I get tons of warning messages that makes the table unreadable

Hi @rpearson! Thank you for reaching out to us on the forums!

I’m sorry to see this issue is occurring, and preventing you from being able to use the Adminer interface properly. I understand an issue like this can be frustrating, and we want to help find a solution.

I have attempted to replicate the issue on my end, and I was able to do so. This does appear to be a development related issue within Adminer. I am going to be escalating this with our DevKinsta developers to explore what options might be available to resolve this issue. We will update you as soon as we have more details to share.

We thank you for your patience while our team investigates. Please don’t hesitate to reply if you do have any questions in the meantime. We’re always happy to help!

Best regards

Same is happening to me, hope we can get this resolved, I am unable to pull from Kinsta and run sites locally at this time =(

1 Like

having the same issue. warnings make it difficult to use the interface, but it is still usable.

good reason to stick to TablePlus.

1 Like

I’m having the same issue.

1 Like

@designlobby

Thank you for reporting that; I’ve added your report to our request to our development team.


I am having this issue as well.

1 Like

Hi @Steven_Burns Welcome to the Kinsta Community.

Thank you for reporting the same issue to our attention. I have also forwarded this to our development team. We will update you as soon as we have more information/update.

Same issue here…

1 Like

Ciao, anche io ho lo stesso problema con un sito wp installato in locale tramite la procedura automatica di devkinsta 2.13.2

Sapete come poter risolvere?

Grazie!

1 Like

Hi, is this resolved?

1 Like

Hi @Nio, Welcome to the Kinsta Community!
I am sorry to hear that you are having similar issue. I have added this report to our development team as well. We will keep you posted with the updates.

@mbird1981 Unfortunately, the issue remains unresolved and has been reported to our development team. We are currently awaiting their response.

1 Like

Hi @merineth ,

I found my solution here
“Local switched from Adminer to AdminerEvo in 8.3.1, which includes fixes for several PHP warnings like the ones you shared. If you update Local you should no longer see them.”

I found this maintained adminerevo-docker
Joined it to DevKinsta network and linked it with devkinsta_db container:
docker run --network devkinsta_network --link devkinsta_db -p 15201:8080 ghcr.io/shyim/adminerevo:latest

Works smoothly.

I believe DevKinsta should move from Adminer (latest release v 4.8.1, 2021-05-14 ) to adminerevo distro ( latest release 4.8.4 2024-04-07 17:42)

Thanks

2 Likes

Hi @alonbg, We appreciate you sharing your solution with us and I am happy that this has sorted out the adminer issue.

This is incredibly valuable, not only to the community but to us as well. I’ll pass your suggestion along to the development team for review.

Thank you for contributing your insights and solutions to the community!

1 Like

@merineth I’m glad it helps
It would be even more valuable to those open projects that DevKinsta depends on, like Adminer, is for KInsta to fork those projects. Even if not changed. Allowing you both to freeze your ingration point and with that the ability to issue early bug fixs to these forks which in turn translates to keeping your own crowed happy and content on one hand and on the other contributing back to the community by pull requesting these fixes upstream, as well as the positive impact of this declaration-of-usage by Kinsta, being a resposible industry leader by it’s own right, on the community growth & well-being where ultimetly all sides benafit from.

I have exactly the same issue

What is the solution to upgrade adminer?

Do I have to type this command in docker?
docker run --network devkinsta_network --link devkinsta_db -p 15201:8080ghcr.io/shyim/adminerevo:latest

If yes, where?

thanks

Hi @laurentngu :wave:

Welcome to the Kinsta Community!

I tested the workaround shared by @alonbg and it worked for me. I’m using a Windows 10 machine, and below are the steps I followed:

  1. Run Docker Desktop as an administrator.
    image

  2. Open CMD and run it as an administrator.
    image

  3. In CMD, run the following command:

docker run --network devkinsta_network --link devkinsta_db -p 15201:8080 ghcr.io/shyim/adminerevo:latest

  1. Check the Docker Desktop to confirm that the container is running.

  2. Go to http://localhost:15201/ and log in to the Devkinsta database using the following information:

System: MySQL
Server: devkinsta_db
User: root
Password: (You can find the password in Devkinsta >> Your Site >> Database section.)
Database: (You can leave this empty.)

Please note that you’ll need to manually access http://localhost:15201/ to use adminerevo, as the “Database manager” button in Devkinsta will still bring you to our Adminer UI.

I hope this workaround works for you.

2 Likes


I am using ubuntu 24.04 and It comes with these warnings. I have tried lots of solution but nothing worked at all.

Hello @Aditya_Amin

Our developers are still working on the permanent fix.

In the meantime, have you tried the workaround Adrian proposed above?

@Adrian_L Thanks for the temporary solution. It works to me.

Hope devKinsta releases next updated new version soon. And as I see devKinsta is a little bit behind Local.

1 Like