Devkinsta_nginx will not start

(HTTP code 500) server error - Ports are not available: exposing port TCP → listen tcp bind: An attempt was made to access a socket in a way forbidden by its access permissions.

I deleted the containers and uninstalled DevKinsta. I reinstalled DevKinsta, restarted Docker Desktop and ran DevKinsta and this is the error I am getting.

Whomever makes WordPress dev simple will make a f c i g killing…

In case it matters…

i7 SNAG- 5-2-2024 9.57.33 AM

I reset Docker Desktop to factory settings and tried again…still DevKinsta cannot start docker container

i7 SNAG- 5-2-2024 11.02.34 AM

And there is a vulnerability in one of the packages…

Hi @kittenofd00m ! :wave:

That’s odd - usually that DK0009 error will only pop up when the containers need to be started: DevKinsta Error Codes - DK0009

However the initial error (An attempt was made to access a socket in a way forbidden by its access permissions) tends to come from the specific platform in question.

Are you able to run this command in your Command Prompt, and provide the output?

netstat -aon | findstr :55313

I used Revo Uninstaller Pro and removed all of Docker Desktop and all of DevKinsta and re-installed them and it seems to be working OK for now.

Glad to hear you were able to get it resolved! I expect it was some other service trying to use that same port :thinking:

If you do have any other questions, please let us know.

1 Like

There is one thing…Adminer seems kind of borked. If I could get it to working and connect my PHPStorm I’d be one happy devkinsta-ite.

Hi @kittenofd00m I am sorry about the adminer issue, we are still waiting for an update from our development team. However, I’d like to share a possible workaround on this post from one of our community members. Kindly check it this works for you as well and let me know how it goes.

1 Like

Thank you, but I have no idea how to do that. I don’t know where to put that command or if the port numbers would be the same or how to know if it worked correctly.

This is why I am using the DevKinsta tools – so I don’t have to know all of that just to work on a WordPress site locally.

If it is truly this easy, I see no reason that the devs can’t just roll that into DevKinsta’s tool and give us a new download link.


Why not just use PHPMyAdmin? I get that Adminer and AdminerEvo seem to have more features, but those features don;t matter if the code is not updated regularly.

The Adminer guy seems to still be alive ( but maybe he just doesn’t want to do Adminer any longer.

LocalWP has updated to AdminerEvo but, IMHO, having something that is updated regularly usually means using the most used app - like PHPMyAdmin. It may not have all of the bells an whistles of and Adminer fork, but having something is reliable seems to be preferable to something that is not.

this can provide a temporary short term solution
or with PHPMyAdmin as suggested by @kittenofd00m - docker run --name phpmyadmin --network devkinsta_network --link devkinsta_db:db -p 15201:80 phpmyadmin

note: using 15201 as 15200 is already being used by Adminer container


  • windows - WSL prompt
  • mac - terminal app prompt

paste the command + enter
browse to or localhost:15201

1 Like

Thanks very much for that phpMyAdmin docker command! I had to download Windows Terminal from the Microsoft Store and I ran the command from there using the database username and password listed in the DevKinsta UI for the WordPress Instance I was running.

This is fantastic! Now I just have a few more things to figure out (like where is the PHP executable to connect it to PHPStorm and basically how to use PHPStorm to connect to and edit this WordPress instance in DevKinsta/Docker).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.