Dk0009 Docker does not start

I very new to using DevKinsta en Docker and have a problem.
Docker won’t start and if I trie to start the different containers, one is giving an error.

error starting: ‘devkinsta_nginx’ - ‘Error: (HTTP code 500) server error - Ports are not available: exposing port TCP → listen tcp bind: Er is geprobeerd toegang te verkrijgen tot een socket op een volgens de toegangsmachtigingen niet toegestane manier.\n’ +
’ \n’ +
’ at C:\Users\Dirk\AppData\Local\Programs\DevKinsta\resources\app.asar\node_modules\docker-modem\lib\modem.js:323:17\n’ +
’ at getCause (C:\Users\Dirk\AppData\Local\Programs\DevKinsta\resources\app.asar\node_modules\docker-modem\lib\modem.js:353:7)\n’ +
’ at Modem.buildPayload (C:\Users\Dirk\AppData\Local\Programs\DevKinsta\resources\app.asar\node_modules\docker-modem\lib\modem.js:322:5)\n’ +
’ at IncomingMessage. (C:\Users\Dirk\AppData\Local\Programs\DevKinsta\resources\app.asar\node_modules\docker-modem\lib\modem.js:294:14)\n’ +
’ at IncomingMessage.emit (node:events:525:35)\n’ +
’ at IncomingMessage.emit (node:domain:489:12)\n’ +
’ at endReadableNT (node:internal/streams/readable:1359:12)\n’ +
’ at process.processTicksAndRejections (node:internal/process/task_queues:82:21)’

( sorry, is in Dutch )

Windows 10 Pro

Hope someone can heklp me with this.

Hi @Dirk_Molman :wave: and welcome to our Community Forum!

Thank you for reporting that error message above (which seems related to the Docker itself most probably) - though I’ve never encountered such error with my Docker on Windows environments (10 pro and 11 pro).

Anyway, have you tried the solution as documented on our public documentation here for that specific error code ( dk0009 )

So, please kindly try to quit and close/shutdown the DevKinsta completely (not only minimized), and keep the Docker Desktop running on your Windows - then please open CMD (command prompt) on your Windows and there run the following command (as shown in that documentation above):

docker kill devkinsta_fpm && docker kill devkinsta_nginx && docker kill devkinsta_adminer && docker kill devkinsta_db && docker kill devkinsta_mailhog

It may look like this (I ran that command on my CMD on my Windows 11 pro computer) to stop all of DevKinsta related Docker containers.

Once done, you may want to re-launch/restart your DevKinsta and see if it will load properly :pray:
If it’s still not working, please do let us know what’s your Docker Desktop version? and if you could also please provide the screenshot of that error message and whatnot - so those might help us to check/investigate further!

Best regards,
Agus Utomo

after I ran the cmd procedure, everything works.

Awesome! :clap:
Glad to hear that command line helped and to see everything now works on your end @Dirk_Molman ! :bowing_man:

Best regards,
Agus Utomo

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.