DivKinsta gets stuck at "Starting docker containers"

Although the issue sounds similar to this one, since the docker containers are actually created, I think my issue merits its own thread. DevKinsta freezes at "Starting docker containers"
If the mods disagree, kindly merge them.

When I start DevKinsta, the splash screen gets stuck at “Starting docker containers”.

kalle@tapedeck:~$ dev-kinsta 
13:17:05.669 › {
  constructor: 'TypeError',
  stack: "TypeError: Cannot read property 'getPath' of undefined\n" +
    '    at Object.getConfig (/opt/DevKinsta/resources/app.asar/main.prod.js:2:1967048)\n' +
    '    at Module.<anonymous> (/opt/DevKinsta/resources/app.asar/main.prod.js:2:1967884)\n' +
    '    at __webpack_require__ (/opt/DevKinsta/resources/app.asar/main.prod.js:2:261)\n' +
    '    at /opt/DevKinsta/resources/app.asar/main.prod.js:2:1560\n' +
    '    at Object.<anonymous> (/opt/DevKinsta/resources/app.asar/main.prod.js:2:1607)\n' +
    '    at Module._compile (internal/modules/cjs/loader.js:967:30)\n' +
    '    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1004:10)\n' +
    '    at Module.load (internal/modules/cjs/loader.js:815:32)\n' +
    '    at Module._load (internal/modules/cjs/loader.js:727:14)\n' +
    '    at Function.Module._load (electron/js2c/asar.js:769:28)'
[bugsnag] Loaded!
kalle@tapedeck:~$ docker system info
 Context:    default
 Debug Mode: false
  app: Docker App (Docker Inc., v0.9.1-beta3)
  buildx: Build with BuildKit (Docker Inc., v0.5.1-docker)

 Containers: 5
  Running: 0
  Paused: 0
  Stopped: 5
 Images: 6
 Server Version: 20.10.7
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: true
  userxattr: false
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
 Cgroup Version: 1
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: runc io.containerd.runc.v2 io.containerd.runtime.v1.linux
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: d71fcd7d8303cbf684402823e425e9dd2e99285d
 runc version: b9ee9c6314599f1b4a7f497e1f1f856fe433d3b7
 init version: de40ad0
 Security Options:
   Profile: default
 Kernel Version: 5.4.0-77-generic
 Operating System: Linux Mint 20
 OSType: linux
 Architecture: x86_64
 CPUs: 4
 Total Memory: 15.6GiB
 Name: tapedeck
 Docker Root Dir: /var/lib/docker
 Debug Mode: false
 Registry: https://index.docker.io/v1/
 Experimental: false
 Insecure Registries:
 Live Restore Enabled: false

WARNING: No swap limit support

I tried docker kill devkinsta_fpm && docker kill devkinsta_nginx && docker kill devkinsta_adminer && docker kill devkinsta_db && docker kill devkinsta_mailhog as per the FAQ, but to no avail. I also rebooted my system. Anything else I can try? Thanks for your support!

Hi @kalle ! Welcome to DevKinsta!
Could you tell me a bit more about the OS and what version of DevKinsta you’re running? It sounds like a permission issue. Would you be able to re-install DevKinsta and let me know if that helps?

Hi @michael , thanks for your reply!

I use Linux Mint 20 ( Ubuntu 20.04 base) and DevKinsta 1.1.7

I tried purging and reinstalling DevKinsta, now I get a DK0021 (WordPress site setup failed) when trying to setup a new site.

What are some permissions I should look at here? FYI, it did run great on my system for a week, before I started experiencing issues.

Hi @kalle. While Linux Mint may be based on Ubuntu, we don’t officially support Linux Mint. I suspect it could work, but wanted to mention we haven’t properly tested Linux Mint.

There’s some discussion here on permissions that were set for Kubuntu that might help: DK003 Couldn't install docker on Kubuntu Linux - #5 by dexter

We haven’t heard back from you on this topic in a while. However, if you do need further assistance you can simply start a new forum thread. Thank you again for using DevKinsta. Let us know if you need further assistance! :wave: