DK0083 Unsupported docker volume path on WSL

Hi, I just started using devkinsta, after being a happy kinsta customer for years, and installing it on my main computer, I run into the error (on DevKinsta startup):

DK0083 Unsupported docker volume path on WSL

The trouble shooting page suggests I reinstall docker. I tried that twice, along with reinstalling DevKinsta. I have tried using Windows containers and Linux containers. I also tried changing the container location. I can create sample containers and they run fine in docker, but DevKinsta produces the same error. I tried updating WSL, and it updated and lists as version 2. The list of containers in WSL shows up as the default docker ones (when using WSL, they are started, stopped when using HyperV).

So, what am I doing wrong? Any ideas would be very much appreciated :slight_smile:


Hello @gregadev and welcome to the DevKinsta Community!
Can you please send me a copy of your main.log file via DM? You can find it inside the following folder:
We’d like to give a look at it and help you find the culprit.


Thanks :slight_smile: Dming my latest log. Unfortunately to me it doesn’t provide extra detail, hopefully it does to you, there’s atleast a stacktrace :slight_smile:

Thanks again!

Thank you for providing the log Greg, can you please also share your Windows, DevKinsta and Docker version?

Windows 10 pro - 10.0.19041.1806

And the latest of both Docker and DevKinsta:

I tried to install DevKinsta for all users, thinking I hadn’t tried that - but noticed the certificate was revoked? I re-downloaded the installer, still the same thing…I don’t think that is relevant here, but perhaps I’m getting the wrong file from the site?

Hi @gregadev as I don’t have a Windows machine where to try to replicate the issue, I’ve asked our devs for suggestions on where the issue might be. I’ll get back to you as soon as I have an update :+1:


Hello @gregadev, sorry it took so long. Our devs are still investigating the issue but are suggesting performing a temporary downgrade so that you can use DevKinsta while they investigate this further. You can download the previous version from here


Thanks Alessandro! I don’t know what the issue is, but leaving Docker installed and using the previous version you provided worked wonderfully - started up and worked :-). I had tried to find older installers off the site before posting here, but couldn’t, so I’ll be sure to keep this download saved in case I need to reinstall.

While I’m sure there’s lots of possible reasons why the newest version didn’t work for me - the startup time for the installer made me wonder if the newest has a low tolerance for really slow internet speed? My internet is very slow (400kbps)? That’s the only added info I can offer though.

Happy to test the next version when it comes out to see if it works, - if that’s helpful, just message me.


Hi Greg,
our devs believe this might be due to the selection of the kernel type, but are still investigating the matter. I’ll try to keep in mind to update this thread to let you know when the next version is out, but if I fail to do so, please keep an eye on this thread, we usually post there all the updates to a minor version.
Glad the downgrade worked well :tada:

All the best,

Hello there,

I had the same error message and I was able to get rid of the problem by simply creating the following directory:


I got the idea from this post.

Maybe that will work for you as well!

Kind regards

Hey there @TantalizingToby! :wave:

Welcome to the Kinsta Community!

I’m glad to hear you were able to resolve the issue on your end. Thanks for sharing what worked for you so that other users in the forum may benefit from your findings.