Download of remote site fails

Download from Live fails, I have tried several times, including re-downloading DevKinsta and deleting the site from local and downloading again, but each time it stops at 49% progress, with no resolution.

I also checked the main.log, but could not find any mention of an error that might be applicable. Has anyone else experienced a similar error?

Hello @Minami :waffle:

What is the operating system version you are using and what version of DevKinsta are you using? Did you try running DevKinsta as an Administrator and what happens when you do? Could you send the main.log here?

Kind regards

Thank you for your support.

Operating System: macOS Version 14.5 (23F79)
DevKinsta: The latest version available for download from the site
Docker Desktop: Version 4.28.0 (139021)

Have you tried running DevKinsta as an Administrator?

Yes, I believe I am running it as an administrator. How can I confirm if it is running as an administrator?

main.log (434.8 KB)

These are the steps to try and run it as administrator:

  1. Locate the file you want to run as an administrator.
  2. Hold down the “Control” key on your keyboard and click on the file.
  3. From the context menu, select “Open” while still holding down the “Control” key.
  4. If prompted, enter your administrator credentials.
  5. Click on “Open” to allow the file to make changes to your system.

Also, when pulling site from Kinsta, on which step does it fail?


when pulling site from Kinsta, on which step does it fail?

It fails every time just before the download of the remote site is complete.

Hi @Minami! Thank you for your reply!

I have reviewed the main.log file further and did notice it appears the rsync process is not completing as expected. I do see a warning indicating that under your theme’s directory (/www/sitename/wp-content/themes/themename) the node_modules/.bin/uuid symlink has no referent. This looks like it could be causing the rsync process to fail to transfer all files and could be resulting in this issue.

Do you know if this symlink is required for proper site function? Or, would it be possible for you to create a backup of your site via MyKinsta, and then remove this symlink using either SFTP or SSH. Then after removing this symlink path try the import again?

You may find a link to our help article below that goes over how to connect to your site via SFTP to manage files:

If you do have any questions please don’t hesitate to ask. We look forward to hearing from you!

Thank you for your comment! It’s very helpful.
I’ll try the steps you advised!