Issues with installation

Hi there, this app looked promising, but I’ve been having some problems getting things pulled from Kinsta that have been quite frustrating. I’ve spent the last two days trying to get my sites down to DevKinsta from Kinsta.
Issues I’ve faced:

  1. Pulls often fail and then can’t be cancelled. Removing the ini file and / or editing the json doesn’t resolve the issues.
  2. If I’m able to pull the sites successfully, but one of them fails it seems to end up corrupting all of the sites (404s, ssl errors etc.) despite them having been working up until that point, forcing me to restart the process form zero again, re-downloading everything only to hit the same walls when things fail again at some point.
  3. Same issues when creating a new site from scratch. Eventually if there is a failure, everything becomes corrupted.

I read that there is an update coming. Is there an ETA on this? I’ve now lost a couple days time on this having expect that the process would be as reliable as Kinsta has always been. Thanks

Hi @jdh1178, welcome to DevKinsta!

Version 2.6.0 has just been released. Can you try completely uninstalling DevKinsta/Docker then starting over with this version?

I’ve never seen anyone have the issues you have described but hopefully the new version helps. If not please reach out!

Hi Kevin. Yesterday I made some more attempts and it seems the issues are related to something in the config json that goes wrong. If with each attempt I backed up the config json, when things went wrong I was able to simply revert to the previous json backup I’d made so that I could continue without starting from scratch. This seems to have worked, allowing me to (slowly) get through each site again without the need to begin from scratch. I’m nearly done, but will try the new version and see how we go.

I’d prefer not to spend the day downloading everything again, so will see how we go with the new version without deleting everything and if problems persist, will then proceed with your instructions. Thank you.

Hi Kevin. Once again, everything was going fine and I got close to finishing all site downloads (using the updated version and the existing files without redownloading from scratch) and then ran into an issue where one site failed and now the Nginx container won’t start as it seems to be looking for a non-existent ssl certificate from the site that failed. There is also a persistent warning about obsolete max_header_size that is always showing in docker.

nginx: [warn] the "http2_max_header_size" directive is obsolete, use the "large_client_header_buffers" directive instead in /etc/nginx/nginx.conf:17

2022/05/13 04:52:04 [emerg] 1#1: cannot load certificate "/www/kinsta/ssl/mysite.local.crt": BIO_new_file() failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/www/kinsta/ssl/mysite.local.crt','r') error:2006D080:BIO routines:BIO_new_file:no such file)

nginx: [emerg] cannot load certificate "/www/kinsta/ssl/mysite.local.crt": BIO_new_file() failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/www/kinsta/ssl/mysite','r') error:2006D080:BIO routines:BIO_new_file:no such file)

Other things I noticed
In case its helpful for troubleshooting, I also had several other errors during install attempts:

  1. Run size calculations (said 40.5 gib total instead of 4.5)
  2. Non-description ‘errors’ message in the devkinsta loading screen while opening
  3. Could not restart nginx service error DK0073

A friend is coming by to help and hopefully has some ideas as the process is way too slow and unpredictable to start again from scratch to only fail again in the end.

I have a question for you please:
If I have already downloaded everything and have the backup.sql files in the folders, is it possible to somehow import those into fresh installs without going through the process of re-downloading? I’m already well over my transfer limit on kinsta and takes all day to redownload…Thanks

Just to follow-up:

  1. Erasing the nginx_sites file for that site resolved the issue with the certificate that was missing.
  2. The issue with the odd size due to a wp plugin that went wrong somewhere caching mega giant files that never completed that I was unaware of, so the calculation by DevKinsta was actually correct. So, when trying to install that site DevKinsta was unaware that I didn’t have the disk space to complete it (didn’t warn me) and I was unaware that the size was indeed correct and not a bug. Removing the huge files resolved it, though it would have been nice to have a warning before installing that there isn’t enough disk space.

It looks now as if I’ll be able to complete the remaining downloads and if I run into any more issues, keeping the last json .config file on hand from the previous pull will get me through them.

Thanks for you time!

1 Like

Thank you very much for the detailed updates and information, @jdh1178! This will definitely help if anyone has similar issues.

1 Like

Unfortunately the problems continued. Some sites install fine and then at some point everything craps out. Fresh install of both Docker and DevKinsta and my fifth time around trying to download. DevKinsta told me another site was 59GB. I confirmed with Kinsta support that it is only 2GB. Not sure what’s going on, but it seems to me that there are some bugs to work out still and I have to move on. Will perhaps try a manual import as instructed here or will return to wp-local/wp-migrate until DevKinsta is improved.

Here is a link to manual installation for anyone interested and having troubles with the sync:

Sorry for all these issues @jdh1178.
If they keep occurring, please private message your main.log files to me as well as the urls for the sites that are causing errors/not having their size calculated correctly. I’ve never seen the exact errors that you are experiencing but our devs can definitely investigate if given enough log data.