Failed to upload local sites on push to staging DK0065

Tried multiple times and still get an error whe uploading local sites. Any help around? We need to urgently push our page.

Thanks for your support!

Hi @Mikyboy, welcome to DevKinsta!?
DK0065 can be caused by many things so I’ll need to see your main.log for the precise log information. Can you please private message that to me?
You can see instructions for how to find the file here: DevKinsta Error Codes - Kinsta®

Sure thing, thanks for your help!

I have already tried this solution to a similar ticket - without success though:

Thanks @Mikyboy. In your case I’m seeing Error: rsync error: error in rsync protocol data stream (code 12) at token.c(476) [sender=3.2.3]

How far is this getting with the upload?
Another test you can do is try pushing this to a different staging site(if you have more than one in MK)

So far it’s looking like a networking issue but I’m still investigating.

So I’m able to establish connections between my PC and your staging without issue so the problems seems to be purely during the transfer. This is my recommendation due to how rsync works:

  1. Remove any unnecessary large files from your local file directory before the Push. This includes and old zip files that you may have of past backups.

  2. Do the same on staging or delete everything in the ~/public directory on staging to keep rsync from comparing local to remote every time it transfers data. That can help speed up the process/make it more consistent.

If you completely delete everything in Staging, remember to reinstall the Kinsta MU Plugin after the transfer is complete.

If this doesn’t work, please send me the new main.log file.

Thank you!

Kevin you r the man! Cant believe how simple the solution now was. Your are right, there was a large old restore file. Just killed it and upload went fine!

Thanks for the great support!

1 Like

Awesome, I’m so glad that fixed it!

1 Like