Urgent: DevKinsta DK0065 while pushing site

The link I shared has the instructions. The location depends on your operating system:

Sent privately the main.log. Deleted the one uploaded here.

1 Like

Thank you, it loks like it could be this error:
[warn] [terminalExec] Error: cp: can't stat '/tmp/.ssh': No such file or directory

I’ve never actually seen this before, though. Can try going to the DevKinsta settings, logging out of MyKinsta, then logging back in before trying again?

I tried before not working.

Can you first delete the ~/DevKinsta/.ssh directory?

Try deleting that first then logging in again

Same error. See log

Okay, this is looking like a Mac issue. Can you open terminal and try to create that directory? Something like this: mkdir /tmp/.ssh

THen we’ll see what the next error after that is.

Below is the terminal output. Same error

universedocs:.ssh kumarmuthaiah$ ls -al /tmp/.ssh
total 0
drwxr-xr-x 2 kumarmuthaiah wheel 64 Jul 5 22:40 .
drwxrwxrwt 7 root wheel 224 Jul 5 22:40 …
universedocs:.ssh kumarmuthaiah$

Can you manually create the .ssh directory?
What does terminal say if you run this command that is failing:

stat /tmp/.ssh

And if it doesn’t exist:

mkdir /tmp/.ssh


16777225 8836814 drwxr-xr-x 2 kumarmuthaiah wheel 0 64 “Jul 5 22:40:58 2022” “Jul 5 22:40:58 2022” “Jul 5 22:40:58 2022” “Jul 5 22:40:58 2022” 4096 0 0 /tmp/.ssh

Is it the remote server directory?

Strange, no it should be the local directory since it is a [terminalExec] command. I will check the remote directory as well, though. I believe the only other place that could be coming from is the Docker devkinsta_nginx container.

I will check and see if any developers are available to explain what is causing this.

ok please. ok please ok please

possible to reply today? I’m waiting

OK bye see you tomorrow…hope tomorrow it is solved.

Sorry @kumarmuthaiah, I couldn’t get back to you sooner. I will try to get you information tomorrow.

I solved myself, by importing wordpress site through SFTP, instead of using DevKinsta. DevKinsta Push is not stable i feel. Anyway Thanks. My website is working, but needs some code change i know what to do. My website is working in staging environment.

1 Like

Thank you for letting us know; I’m glad that worked.

Sorry here because it looks like this issue just began for Mac a few hours ago. I have submitted to our developers and I will still let you know when they have this fixed so that DevKinsta works like normal.

Hi @kumarmuthaiah, please follow the following steps to fix this:

  1. Open Docker Desktop and go to “Images”
  2. Remove/Delete “kinsta/devkinsta_rsync-ssh”

The next time you run a sync for a website it should download a new version of “devkinsta_rsync-ssh” which should fix fix. Please let me know if it doesn’t.