I'm getting a DK0029 Error on Devkinsta

Hi there :slight_smile:

Thank you for your updates! Glad to hear that you were able to fix that previous issue (with WSL 2 thing).

About the max_execution_time , if you create a simple php script in your site’s folder (which contains: <?php phpinfo(); ?> code) and load / call that PHP file on your browser, it will show the value of the max_execution_time variable as 300 by default.

If you want to increase that more than 300 (e.g.: to double it or more), you could go to your DevKinsta → Sites → site name in question → click the wrench icon (on the left side) → scroll down and locate the “PHP.ini Editor” .
There you can add this line in that editor, for example: max_execution_time=600 (and click the “Save changes” button)

Then if you refresh your browser for that phpinfo() page, that variable should now have increased to that new value you set. Like the following for example:

As for the PHP Workers, in order to change/increase that value you can do the following:

  1. Go to your Docker Desktop, and click on the “Containers” section, and click the container name “devkinsta_fpm” (in the Name column)

  2. In that “dev_kinstafpm” container page, click on the “Terminal tab”.
    Then type the following commands (1 by 1):

  • sudo apt-get update
  • sudo apt-get install nano
  • nano /etc/php/8.0/fpm/pool.d/www.conf
    (replace the 8.0 with the actual PHP version you use for this local site in DevKinsta)
    it will show something like this:
  1. You may want to update that pm.max_children higher than the current number shows there (as per my example above it’s currently set to 8 )

  2. Once you change that with new number, save it by pressing Control O (in that nano editor)

  3. Then exit the nano editor by pressing Control X
    Still in that devkinsta_fpm container’s terminal, you can type this command to make sure that has been saved/changed properly:
    grep "max_children" /etc/php/8.0/fpm/pool.d/www.conf

  4. After that, you just need to restart that devkinsta_fpm container.
    Still on that same page, click on the “refresh” icon/button to restart that container

Done, the PHP Workers for that specific PHP version should now have been increased already.

You may then try to access the site again and see if it’s no longer showing 504 gateway timeout. If it’s still timing out (504), you may want to try to increase more (with the above steps and try again).


So I decided to change it over to hyper-v because the server was extremely slow, it would take 20-30 seconds per page load. I understand that’s a common workaround for this software. I have tried my best and I’m currently stuck.

I upgraded my computer from windows 11 home to the pro version, and I activated hyper-v and then reinstalled docker and devkinsta.

I’m waiting for the website to download, but it’s only at 7.6gb out of 20gb, and that’s about 6 hours of progress.

Last time I downloaded a site, it was much faster, like 30 minutes for complete download.

This is my second time trying to download the site, last time it got stuck on 20gb/20gb for hours and it wasn’t progressing. I did see a note in the logs mentioning a pipe broken about that time, but I don’t know if the abnormally slow download could be due to something else.

Here’s a screenshot and some logs.

main.old.log (1.0 MB)
main.log (557.9 KB)

Hi there, thank you for your reply and update! :slight_smile:

I’ve checked those 2 main log files you provided, but yeah I didn’t see any “Broken pipe” or “rsync” error messages logged in those log files this time. I’m still not sure what’s causing this slow download process (and that it just stuck/stayed at 7.63GiB out of ~20GiB for hours) as there’s no other useful information in those 2 main log files.

Since you’re now using Hyper-V (no longer using WSL2 base engine), could you please try to temporarily increase the Docker resources (in your Docker Desktop → Settings → Resources → Advanced section), and on that page try to raise the amount of CPU, Memory & Swap that the Docker will be able to use (and then Apply the changes and restart). See if that will make any improvement/difference if you can try to import the site again? :crossed_fingers:

If you have tried above but still getting the same issue (always stuck with the download process - and still no broken pipe or rysnc error in the main.log file), you may want to consider an alternative method to import the site manually from the backup - with the step-by-step mentioned on our documentation here.
Hopefully with that manual method, you will be able to import your site successfully to your DevKinsta on your local computer.