Non-saying error

CleanShot 2022-07-07 at 11.16.55

Hi there,

I get the following error when starting DevKinsta.
Sometimes I get a DK0005 or DK0009 error as well.

When pressing “Try Again”, I see “Updating Site URL’s” for 1 second and then “errors.” again.

Hi @jarno, thanks for reaching out. Is this the latest DevKinsta release that you are trying (2.6.0)? Can you please use these instructions to get your main.log file? You can then private message it to me: DevKinsta Error Codes - Kinsta®

Hi @Kevin where do I find the main.log file? It’s not in the logs folder.

The location depends on your Operating System but these are the instructins:

Thanks! I’ve send you the main.log file.

1 Like

I’m seeing this error: nginx service failed. Encountered an error: Error: Command failed: docker exec devkinsta_nginx nginx -s reloadso maybe there is something wrong with the NGINX container. Can you try this:

  1. Completely close DevKinsta/quit the process.
  2. Completely stop/quit Docker (it might be easier to restart your computer)
  3. Delete your devkinsta_nginx container
  4. Start DevKinsta again

Does it still stop at that step? If so please share the new main.log file and I will have to ask our developers. I think there is just something going wrong with Docker.

Still the same ‘errors.’ error. I’ll send you the new main.log file

Got it, thank you. I’m going to review this some more and share it with our developers since this does not look like a common error. Can you please share the following:
Operating system/version
Docker Desktop Version
DevKinsta Version

macOS Monterey 12.4
Docker Desktop 4.9.1 (81317)
DevKinsta Version 2.6.0 (

1 Like

Thanks @jarno. I will share everything with our developers and get back to you this week.

One more thing @jarno, can you run this command in terminal and screenshot what it says:
docker container list
For example, this is what mine shows:


Is it just remaining stuck on “restarting” every time you check it?
Can you copy the container ID of the devkinsta_nginx container and run this:

docker container rm CONTAINER_ID

After that try starting DK again and see if it remains stuck on “restarting.”

Can you also screenshot your Images page in Docker Desktop? I’d like to compare the versions with mine

Hey @Kevin - I can’t remove the container because it’s stuck on restarting. I can only delete the container in Docker’s UI. But after restarting DevKinsta, I get the same error.

Okay so docker rm devkinsta_nginx didn’t work because it was restarting? Can you follow these steps.

  1. Run this command docker stop devkinsta_nginx
    If that doesn’t work try docker rm -f devkinsta_nginx
    If there are no errors please run docker container list and screenshot what you see. Please screenshot any errors you receive otherwise.

  2. Disable auto restart for Docker containers with this command:
    docker update --restart=no $(docker ps -a -q)
    Please screenshot what this command returns for you.

  3. Now completely stop Docker. The easiest way would be to restart your computer…

  4. Take a screenshot of docker container list after rebooting/BEFORE opening DevKinsta. Is devkisnta_nginx still trying to restart? If it’s not there/not restarting, open DevKinsta to see what happens.

So if the issue isn’t progressing at all run this command: docker logs -f devkinsta_nginx. Please share the log output.

Hi @Kevin - I ran the commands and they were successful. Result:

Step 2:

Step 3: docker container list is empty (all containers are “exited”)

Step 4: docker logs -f devkinsta_nginx returns Error: No such container: devkinsta_nginx

Error still persists:

Okay perfect, now can you restart Devkinsta again and see what happens? You will need to run this command again once devkinsta_nginx starts: docker update --restart=no $(docker ps -a -q)

Okay now while it is failing can you run docker logs -f devkinsta_nginx again?
If nothing happens then docker container list again

Ah okay, that’s very helpful. It looks like one of of SSL certificates is missing for some reason. Can you check ~/DevKinsta/ssl for that odanna-1 crt file? Is it missing there too?