This does not seem to be a WordPress installation. Can't create mysql dump. DK0029

Q: Date/Time this occurred (Provide your time zone also)

2024-04-22 16:40:32.413 Australian Eastern Time

Q: DevKinsta Version

Version 2.13.2 ( - Apple Silicon

Q: OS Version

14.3 (23D56)

Q: Docker Desktop Version

4.9.1 (81317)

Q: Were any error codes or messages observed? If so, what were they?

Can't create mysql dump. DK0029
[2024-04-23 08:50:50.997] [info]  Response data: { total: 0, count: 0, start: 0, items: [] }
[2024-04-23 08:50:50.997] [info]  [getSiteMailbox] 0 emails retrieved. for domain mindfulstagingp-1.local
[2024-04-23 08:50:51.005] [info]  [useMailhog] Mail socket opened.
[2024-04-23 08:50:51.214] [info]  [containerExec] Command 'cd /www/kinsta/public/mindfulstagingp-1 && wp --allow-root --skip-themes --skip-plugins core version' on devkinsta_fpm finished with exit code 1
[2024-04-23 08:50:51.215] [info]  [checkWpVersion] site's current version [31;1mError:[0m This does not seem to be a WordPress installation.Pass --path=`path/to/wordpress` or run `wp core download`.
[2024-04-23 08:50:51.215] [info]  [checkWpVersion] site's stored version 6.4.4
[2024-04-23 08:50:51.215] [info]  [checkWpVersion] containerExec response test false
[2024-04-23 08:50:51.233] [info]  [containerExec] Command 'cd public/mindfulstagingp-1 && wp --allow-root --skip-themes --skip-plugins db size --size_format=b --url=http://mindfulstagingp-1.local' on devkinsta_fpm finished with exit code 1
[2024-04-23 08:50:51.233] [error] Error: [31;1mError:[0m This does not seem to be a WordPress installation.The used path is: /www/kinsta/public/mindfulstagingp-1/Pass --path=`path/to/wordpress` or run `wp core download`.
    at file:///Applications/
    at tryCatch (file:///Applications/
    at Generator.<anonymous> (file:///Applications/
    at (file:///Applications/
    at asyncGeneratorStep (file:///Applications/
    at _next (file:///Applications/
    at process.processTicksAndRejections (node:internal/process/task_queues:95:5)

Q: Detailed Description of the Problem
Each time I attempt to download an existing site from Kinsta it fails at downloading the remote site. with the above error code.

The site is a subdomain multisite.

All throughout the log file when attempting to run wp it seems to fail (or maybe just warn) that the site does not appear to be a Wordpress installation. The site is a Wordpress installation but its a rather old and perhaps custom one.

Reading through other issues with this error code it might be relevant that the database is very large. The SQL file I attempted to export from phpMyAdmin is over 1GB.

Hello @George_Butter! :wave:

Welcome to the Kinsta Community!

I tried importing a Multisite using subdomain formatting to DevKinsta and it worked perfectly fine. Therefore, the issue might be specific to the site data you are trying to import. To better understand the problem, please close or quit both the DevKinsta and Docker apps completely. Then, relaunch DevKinsta and try the pull action again. If the issue still persists, kindly send me a copy of your DevKinsta raw main.log file via private message. To locate it, click the question mark icon at the bottom-left corner of DevKinsta and select the option “Reveal log file in File Manager”. We would like to investigate why the DK0029 error is occurring.

Furthermore, please ensure that you have selected the correct option to Pull the site to Devkinsta, as shown in the screenshot below:

We look forward to hear back from you. :slightly_smiling_face: