When I try to pull a Kinsta Site I get this error. What can I do?

Hey @whadaday :wave: ,

can you please send me a copy of your main.log file via DM? You can find it by clicking on the question mark icon at the bottom left corner of DevKinsta and then on Reveal log file in File Manager.
We’d like to give a look at it and help you find the culprit.


1 Like

Thank you for providing the log file Angelo, from what I see, for some reason DevKinsta isn’t able to create a thumbnail of your site and gives up after five attempts. However, I believe that the pull is completed anyway and that the local site should work properly.
Can you test that? If this is the case, we can then focus on the thumbnail issue.


Hi Alessandro,

I don’t think that is the case, since I see now that all my DevKinsta projects are giving the same error “Err_empty_response” error.

So this is an error you see in your browser? I wonder if it’s an issue with the port selector :thinking:
If you go in DevKinsta, then in Settings (the blue circle in the bottom left corner), is the checkbox “Auto-detect open ports” enabled or disabled?

This is enabled. Weirdly enough I see the error “ERR_CONNECTION_CLOSED” also for other local websites

It sounds like the Docker containers are not running, let’s check that. Open Docker, then on the sidebar at the left select the tab Containers. What’s the status of the 5 containers?

Unfortunately they are all up and running

I also get often the “DK0006” error.
After “sudo ln -s “$HOME/.docker/run/docker.sock” /var/run/docker.sock” it works again.

Maybe this helps.

1 Like

Thank you for your reply and update!
Glad to see it works again after you ran that command line :+1:
So we can consider this as resolved then.


Hi Agus,

Unfortunately it didn’t. I know did the following steps:

  • Deleted sites from my local DevKinsta
  • Uninstalled DevKinsta
  • Uninstalled Docker
  • Reinstalled everything

Now I get the error “Something went wrong” when I try to pull a site.

Hey Angelo,

can you please close DevKinsta entirely, delete the old main.logs, retry to pull the site and then send me the newest main.log file? Hopefully that will only contain one single error and it will be easier to spot the issue :crossed_fingers:

Its working again! Thanks for your help. Another question…
I get on all my local sites an “invalid ssl certificate” error/notice…
How can I fix this?

Great to hear it’s working fine again Angelo! :slight_smile:

I get on all my local sites an “invalid ssl certificate” error/notice…
How can I fix this?

I’m wondering if you got “NET::ERR_CERT_INVALID” / “Your Connection is not private” message? and if you’re using Chrome browser (most recent/latest version)?
Have you tried to access the local site(s) with different browser (FireFox for example) and see if the site could be access just fine via HTTPS URL (and no error message)?

You may want to check this other thread about that Chrome browser issue - in case that’s the issue you may be experiencing.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.